Skip to content
Permalink
Browse files

Update futures requirement from 0.1 to 0.3

Updates the requirements on [futures](https://github.com/rust-lang-nursery/futures-rs) to permit the latest version.
- [Release notes](https://github.com/rust-lang-nursery/futures-rs/releases)
- [Changelog](https://github.com/rust-lang-nursery/futures-rs/blob/master/CHANGELOG.md)
- [Commits](rust-lang-nursery/futures-rs@futures-cpupool-0.1.1...0.3.0)

Signed-off-by: dependabot-preview[bot] <support@dependabot.com>
  • Loading branch information...
dependabot-preview committed Nov 7, 2019
1 parent 1446956 commit 8df3bcfad943118598614995a0bf157ff1ff78b5
@@ -12,7 +12,7 @@ gotham = { path = "../../gotham/"}
gotham_derive = { path = "../../gotham_derive/" }
gotham_middleware_diesel = { path = "../../middleware/diesel"}
hyper = "0.12"
futures = "0.1"
futures = "0.3"
mime = "0.3"
log = "0.4"
diesel = { version = "1.4", features = ["sqlite", "extras"] }
@@ -11,7 +11,7 @@ gotham_derive = { path = "../../../gotham_derive" }

hyper = "0.12"
mime = "0.3"
futures = "0.1"
futures = "0.3"
serde = "1"
serde_derive = "1"
tokio-core = "0.1"
@@ -10,5 +10,5 @@ gotham = { path = "../../../gotham" }

hyper = "0.12"
mime = "0.3"
futures = "0.1"
futures = "0.3"
url = "2.1"
@@ -10,5 +10,5 @@ gotham = { path = "../../../gotham" }

hyper = "0.12"
mime = "0.3"
futures = "0.1"
futures = "0.3"
multipart = { version = "0.16", default-features = false, features = ["server"] }
@@ -10,4 +10,4 @@ gotham = { path = "../../../gotham" }

hyper = "0.12"
mime = "0.3"
futures = "0.1"
futures = "0.3"
@@ -11,7 +11,7 @@ gotham_derive = { path = "../../../gotham_derive" }

hyper = "0.12"
mime = "0.3"
futures = "0.1"
futures = "0.3"
serde = "1.0"
serde_derive = "1.0"
tokio = "0.1"
@@ -8,6 +8,6 @@ publish = false
[dependencies]
gotham = { path = "../../../gotham" }

futures = "0.1"
futures = "0.3"
hyper = "0.12"
mime = "0.3"
@@ -8,7 +8,7 @@ edition = "2018"
[dependencies]
gotham = { path = "../../gotham" }

futures = "0.1"
futures = "0.3"
tokio = "0.1"
hyper = "0.12"
mime = "0.3"
@@ -9,5 +9,5 @@ gotham = { path = "../../../gotham" }
gotham_derive = { path = "../../../gotham_derive" }

hyper = "0.12"
futures = "0.1"
futures = "0.3"
mime = "0.3"
@@ -9,7 +9,7 @@ gotham = { path = "../../../gotham" }
gotham_derive = { path = "../../../gotham_derive" }

hyper = "0.12"
futures = "0.1"
futures = "0.3"
mime = "0.3"
serde = "1.0"
serde_derive = "1.0"
@@ -7,7 +7,7 @@ publish = false
[dependencies]
gotham = { path = "../../gotham", default-features = false }

futures = "0.1"
futures = "0.3"
hyper = "0.12"
mime = "0.3"
tokio-openssl = "0.3"
@@ -9,7 +9,7 @@ edition = "2018"
[dependencies]
gotham = { path = "../../gotham" }
hyper = "0.12"
futures = "0.1"
futures = "0.3"
tokio-tungstenite = "0.9"
pretty_env_logger = "0.3"
sha1 = "*"
@@ -29,7 +29,7 @@ mime = "0.3"
# Using alpha version of mime_guess until mime crate stabilizes (releases 1.0).
# see https://github.com/hyperium/mime/issues/52
mime_guess = "2.0.1"
futures = "0.1"
futures = "0.3"
tokio = "0.1"
bytes = "0.4"
mio = "0.6"
@@ -12,7 +12,7 @@ categories = ["web-programming::http-server"]
keywords = ["http", "async", "web", "gotham", "diesel"]

[dependencies]
futures = "0.1"
futures = "0.3"
gotham = "0.5.0-dev"
gotham_derive = "0.5.0-dev"
diesel = { version = "1.3", features = ["r2d2"] }
@@ -15,7 +15,7 @@ license = "MIT/Apache-2.0"
edition = "2018"

[dependencies]
futures = "0.1"
futures = "0.3"
gotham = "0.5.0-dev"
gotham_derive = "0.5.0-dev"
serde = "1.0"
@@ -10,7 +10,7 @@ publish = false

[dependencies]
log = "0.4"
futures = "0.1"
futures = "0.3"

# Middlewares should reference the semantic versions of Gotham that are they compatible with
# and not use relative references such as shown here.

0 comments on commit 8df3bcf

Please sign in to comment.
You can’t perform that action at this time.