Permalink
Browse files

Fix for the duplicate resource error for those using resources 1.0-RC2

  • Loading branch information...
marcpalmer
marcpalmer committed Mar 31, 2011
1 parent 45d8769 commit 8a06ed192324c0ebf2d5b270b3b701824dde8ad3
@@ -1,6 +1,6 @@
class JqueryUiGrailsPlugin {
// the plugin version
- def version = "1.8.10"
+ def version = "1.8.10.1"
// @todo This MUST be updated when you update the version of jquery ui
static JQUERYUI_VERSION = "1.8.10"
@@ -5,26 +5,23 @@ def plugin = appCtx.pluginManager.getGrailsPlugin('jquery-ui')
def jqver = plugin.instance.JQUERYUI_VERSION
modules = {
- 'jquery-ui' {
- dependsOn 'jquery'
-
+ 'jquery-theme' {
resource id:'theme',
url:[ plugin: 'jqueryUi', dir: 'jquery-ui/themes/ui-lightness',
file:'jquery-ui-'+jqver+'.custom.css'],
attrs:[media:'screen, projection']
-
+ }
+
+ 'jquery-ui' {
+ dependsOn 'jquery', 'jquery-theme'
+
resource id:'js', url:[plugin: 'jqueryUi', dir:'jquery-ui/js', file:"jquery-ui-${jqver}.custom.min.js"],
nominify: true
}
'jquery-ui-dev' {
- dependsOn 'jquery'
+ dependsOn 'jquery', 'jquery-theme'
- resource id:'theme',
- url:[ plugin: 'jqueryUi', dir: 'jquery-ui/themes/ui-lightness',
- file:'jquery-ui-'+jqver+'.custom.css'],
- attrs:[media:'screen, projection']
-
resource id:'js', url:[plugin: 'jqueryUi', dir:'jquery-ui/js', file:"jquery-ui-${jqver}.custom.js"]
}
}
Binary file not shown.
View
Binary file not shown.
View
@@ -1,4 +1,4 @@
-<plugin name='jquery-ui' version='1.8.10' grailsVersion='1.2 &gt; *'>
+<plugin name='jquery-ui' version='1.8.10.1' grailsVersion='1.2 &gt; *'>
<author>Marc Palmer</author>
<authorEmail>marc@grailsrocks.com</authorEmail>
<title>jQuery UI resources</title>

0 comments on commit 8a06ed1

Please sign in to comment.