Permalink
Switch branches/tags
release/0.0.3 gub-release-lilypond-2.17.0-1 gub-release-lilypond-2.17.0-1-actual gub-release-lilypond-2.16.0-1 gub-release-lilypond-2.15.95-1 gub-release-lilypond-2.15.42-1 gub-release-lilypond-2.15.41-1 gub-release-lilypond-2.15.40-1 gub-release-lilypond-2.15.39-1 gub-release-lilypond-2.15.38-1 gub-release-lilypond-2.15.37-1 gub-release-lilypond-2.15.36-1 gub-release-lilypond-2.15.35-1 gub-release-lilypond-2.15.34-1 gub-release-lilypond-2.15.33-1 gub-release-lilypond-2.15.32-1 gub-release-lilypond-2.15.31-1 gub-release-lilypond-2.15.30-1 gub-release-lilypond-2.15.16-1 gub-release-lilypond-2.15.15-1 gub-release-lilypond-2.15.14-1 gub-release-lilypond-2.15.13-1 gub-release-lilypond-2.15.12-1 gub-release-lilypond-2.15.11-1 gub-release-lilypond-2.15.10-1 gub-release-lilypond-2.15.9-1 gub-release-lilypond-2.15.8-1 gub-release-lilypond-2.15.7-1 gub-release-lilypond-2.15.6-1 gub-release-lilypond-2.15.5-1 gub-release-lilypond-2.15.4-1 gub-release-lilypond-2.15.3-1 gub-release-lilypond-2.15.2-1 gub-release-lilypond-2.15.1-1 gub-release-lilypond-2.15.0-1 gub-release-lilypond-2.14.2-1 gub-release-lilypond-2.14.1-1 gub-release-lilypond-2.14.0-1 gub-release-lilypond-2.13.63-1 gub-release-lilypond-2.13.62-1 gub-release-lilypond-2.13.61-1 gub-release-lilypond-2.13.60-1 gub-release-lilypond-2.13.59-1 gub-release-lilypond-2.13.58-1 gub-release-lilypond-2.13.57-1 gub-release-lilypond-2.13.56-1 gub-release-lilypond-2.13.55-1 gub-release-lilypond-2.13.54-1 gub-release-lilypond-2.13.53-1 gub-release-lilypond-2.13.52-1 gub-release-lilypond-2.13.51-1 gub-release-lilypond-2.13.50-1 gub-release-lilypond-2.13.49-1 gub-release-lilypond-2.13.48-1 gub-release-lilypond-2.13.47-1 gub-release-lilypond-2.13.46-1 gub-release-lilypond-2.13.45-1 gub-release-lilypond-2.13.44-1 gub-release-lilypond-2.13.43-1 gub-release-lilypond-2.13.42-1 gub-release-lilypond-2.13.41-1 gub-release-lilypond-2.13.40-1 gub-release-lilypond-2.13.39-1 gub-release-lilypond-2.13.38-1 gub-release-lilypond-2.13.37-1 gub-release-lilypond-2.13.36-1 gub-release-lilypond-2.13.35-1 gub-release-lilypond-2.13.34-1 gub-release-lilypond-2.13.33-1 gub-release-lilypond-2.13.32-1 gub-release-lilypond-2.13.31-1 gub-release-lilypond-2.13.30-1 gub-release-lilypond-2.13.29-1 gub-release-lilypond-2.13.28-1 gub-release-lilypond-2.13.27-2 gub-release-lilypond-2.13.27-1 gub-release-lilypond-2.13.26-1 gub-release-lilypond-2.13.25-1 gub-release-lilypond-2.13.24-1 gub-release-lilypond-2.13.23-1 gub-release-lilypond-2.13.22-1 gub-release-lilypond-2.13.21-1 gub-release-lilypond-2.13.20-1 gub-release-lilypond-2.13.19-1 gub-release-lilypond-2.13.18-1 gub-release-lilypond-2.13.17-1 gub-release-lilypond-2.13.16-1 gub-release-lilypond-2.13.15-1 gub-release-lilypond-2.13.14-1 gub-release-lilypond-2.13.13-1 gub-release-lilypond-2.13.12-1 gub-release-lilypond-2.13.11-1 gub-release-lilypond-2.13.10-1 gub-release-lilypond-2.13.9-1 gub-release-lilypond-2.13.8-1 gub-release-lilypond-2.13.7-1 gub-release-lilypond-2.13.7-0 gub-release-lilypond-2.13.6-1 gub-release-lilypond-2.13.5-0 gub-release-lilypond-2.13.4-1
Nothing to show
Find file
Fetching contributors…
Cannot retrieve contributors at this time
50 lines (45 sloc) 1.76 KB
from gub import target
from gub import tools
class Poppler (target.AutoBuild):
source = 'https://poppler.freedesktop.org/poppler-0.49.0.tar.xz'
dependencies = ['tools::libtool', 'tools::glib', 'tools::xzutils',
'zlib-devel',
'fontconfig-devel',
'gtk+-devel',
'libjpeg-devel',
'libxml2-devel',
]
configure_flags = (target.AutoBuild.configure_flags
+ ' --disable-poppler-qt'
+ ' --disable-poppler-qt4'
+ ' --enable-xpdf-headers'
+ ' --disable-gtk-test')
# FIXME: poppler, librsvg, cairo, gtk dependencies?
# gtk+ depends on pango, pango on cairo, cairo on poppler, and poppler on gtk+ and cairo
# TRIED: removing gtk+ dependency from poppler -- no go
# TRY: removing poppler from cairo...
#+ ' --disable-gdk'
#+ ' --disable-splash-output'
#+ ' --disable-cairo' ?
class Poppler__mingw (Poppler):
patches = ['poppler-0.11.2-mingw.patch']
class Poppler__darwin (Poppler):
dependencies = [x for x in Poppler.dependencies
if x.replace ('-devel', '') not in [
'libxml2', # Included in darwin-sdk, hmm?
]]
class Poppler__tools (tools.AutoBuild, Poppler):
dependencies = [
'xzutils',
'libtool',
'glib',
'zlib',
'fontconfig',
'libjpeg',
'libxml2',
]
configure_flags = (tools.AutoBuild.configure_flags
+ ' --disable-poppler-qt'
+ ' --disable-poppler-qt4'
+ ' --enable-xpdf-headers'
+ ' --disable-gtk-test')