Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Sony A7S not providing list of shutterspeed #276

Open
astronono opened this issue May 22, 2018 · 14 comments

Comments

Projects
None yet
6 participants
@astronono
Copy link

commented May 22, 2018

Hello,
I've been working with Jasem Mutlaq to try to solve an issue with indi sony ccd driver not working. In fact it looks like the shutterspeed exhaustive list is provided by libgphoto2 and this seems not working for the Sony A7S.

The discussion we had on this matter is there.
http://indilib.org/forum/ccds-dslrs/2964-indi-and-sony-a7s.html?start=24#26182

Jasem told me to file a bug into the project to see if that could help.

Best regards,
Bruno

@msmeissn

This comment has been minimized.

Copy link
Contributor

commented May 23, 2018

which libgphoto2 version is used?

it might be in a mode where shutterspeed setting is not possible, like manual .. hard to see from the logfile posted.

perhaps get
gphoto2 --list-all-config

@astronono

This comment has been minimized.

Copy link
Author

commented May 23, 2018

its true, A7S is in manual mode by habit, which mode should be used ? I shall provide the list-all-config tonight

@msmeissn

This comment has been minimized.

Copy link
Contributor

commented May 23, 2018

P or Tv would allow setting the shutterspeed I think.

@astronono

This comment has been minimized.

Copy link
Author

commented May 23, 2018

Will try, thanks.

@astronono

This comment has been minimized.

Copy link
Author

commented May 23, 2018

The version used are

gphoto2 -->2.5.17
libgphoto2 --> 2.5.17.1
libgphoto2_port --> 0.12.0

I've done the gphoto2 --list-all-config for the Sony A7S, it looks the section /main/capturesettings/shutterspeed does not return the list of choices with all the shutterspeed.
As a comparison, I have a Canon 500d and did the same extract which shows the list of shutterspeed if that helps.

Bruno
A7S_listconfig_Mode_P.txt
Canon_listconfig_Mode_P.txt

@knro

This comment has been minimized.

Copy link
Contributor

commented Jun 10, 2018

/main/capturesettings/shutterspeed
Label: Temps de pose
Readonly: 0
Type: RADIO
Current: 300/10
END

This is the problem here. For Canon, you get something like this:

/main/capturesettings/shutterspeed
Label: Temps de pose
Readonly: 0
Type: RADIO
Current: automatique
Choice: 0 30
Choice: 1 25
Choice: 2 20
Choice: 3 15
Choice: 4 13
Choice: 5 10
Choice: 6 8
...etc

We have several users who are INDI gphoto driver (based on libgphoto2 library from master) reporting the same problem.

@knro

This comment has been minimized.

Copy link
Contributor

commented Jun 25, 2018

Any hints on what's going on here? Is there anyway I can help?

@elijahparker

This comment has been minimized.

Copy link
Contributor

commented Jun 25, 2018

@knro

This comment has been minimized.

Copy link
Contributor

commented Jun 25, 2018

Right thanks! But since libgphoto2 is supposed to abstract these low-level details for us, I expect to use the same widget shutterspeed across different cameras without worrying on PTP stuff.

@elijahparker

This comment has been minimized.

Copy link
Contributor

commented Jun 25, 2018

@amuro1977

This comment has been minimized.

Copy link

commented Aug 4, 2018

Maybe this can help to find issue:

with Ubuntu 16.04 LTS; Gphoto 2.5.15-2; Libgphoto 2.5.16-2
Sony worked fine under INDI-EKOS..

Now i upgrade to Kubuntu 18.04LTS with last Gphoto and Libgphoto and Sony A7s stop to work as reported before

Some problems appeared after recently release

@knro

This comment has been minimized.

Copy link
Contributor

commented Aug 6, 2018

I'm going to provide a workaround for this in INDI, but the long term solution is for this to be fixed in libgphoto2 of course where the RADIO control is presented instead of TEXT.

@japz

This comment has been minimized.

Copy link

commented Dec 18, 2018

I'm running into the same issue with my Sony A7r iii, when trying to get it to work with Indigo. @knro, did you ever merge a workaround in INDI?

I looked at the source code of the ptp2 driver, but wouldn't know where to begin addressing this. Are the possible options supposed to be read from the camera, or do the txt files such as ./camlibs/ptp2/cameras/sony-a7r3.txt have a function besides acting as reference material?

@msmeissn

This comment has been minimized.

Copy link
Contributor

commented Dec 24, 2018

I have added a fixed list of shutterspeeds to libgphoto2 git now, commit daacc5c

@msmeissn msmeissn self-assigned this Dec 24, 2018

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.