Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP
Dotdeb : PHP5
C PHP C++ Shell JavaScript Yacc Other
Failed to load latest commit information.
TSRM Imported Upstream version 5.6.6
Zend Imported Upstream version 5.6.11
build Imported Upstream version 5.6.6
debian php5 (5.6.11-1~dotdeb+7.1)
ext Imported Upstream version 5.6.11
main Imported Upstream version 5.6.11
netware Imported Upstream version 5.6.6
pear Imported Upstream version 5.6.0
sapi Imported Upstream version 5.6.11
scripts Imported Upstream version 5.6.1
tests Imported Upstream version 5.6.7
travis Imported Upstream version 5.6.8
win32 Imported Upstream version 5.6.11
.gdbinit Imported Upstream version 5.6.0
.gitattributes Imported Upstream version 5.6.0
.gitignore Imported Upstream version 5.6.3
.travis.yml Imported Upstream version 5.6.9
CODING_STANDARDS Imported Upstream version 5.6.4
CREDITS Imported Upstream version 5.6.0
EXTENSIONS Imported Upstream version 5.6.3
INSTALL Imported Upstream version 5.6.4
LICENSE Imported Upstream version 5.6.6
Makefile.frag Imported Upstream version 5.6.0
Makefile.gcov Imported Upstream version 5.6.0
Makefile.global Imported Upstream version 5.6.0
NEWS Imported Upstream version 5.6.11
README.EXT_SKEL Imported Upstream version 5.6.0
README.GIT-RULES Imported Upstream version 5.6.1
README.MAILINGLIST_RULES Imported Upstream version 5.6.0
README.NEW-OUTPUT-API Imported Upstream version 5.6.0
README.PARAMETER_PARSING_API Imported Upstream version 5.6.0
README.REDIST.BINS Imported Upstream version 5.6.0
README.RELEASE_PROCESS Imported Upstream version 5.6.9
README.SELF-CONTAINED-EXTENSIONS Imported Upstream version 5.6.0
README.STREAMS Imported Upstream version 5.6.0
README.SUBMITTING_PATCH Imported Upstream version 5.6.0
README.TESTING Imported Upstream version 5.6.0
README.TESTING2 Imported Upstream version 5.6.4
README.UNIX-BUILD-SYSTEM Imported Upstream version 5.6.0
README.WIN32-BUILD-SYSTEM Imported Upstream version 5.6.0
README.input_filter Imported Upstream version 5.6.0
README.md Imported Upstream version 5.6.0
README.namespaces Imported Upstream version 5.6.0
UPGRADING Imported Upstream version 5.6.8
UPGRADING.INTERNALS Imported Upstream version 5.6.0
acinclude.m4 Imported Upstream version 5.6.1
aclocal.m4 Imported Upstream version 5.6.1
buildconf Imported Upstream version 5.6.0
buildconf.bat Imported Upstream version 5.6.0
config.guess Imported Upstream version 5.6.1
config.sub Imported Upstream version 5.6.0
configure Imported Upstream version 5.6.11
configure.in Imported Upstream version 5.6.11
footer Imported Upstream version 5.6.0
generated_lists Imported Upstream version 5.6.0
genfiles Imported Upstream version 5.6.11
header Imported Upstream version 5.6.7
install-sh Imported Upstream version 5.6.0
ltmain.sh Imported Upstream version 5.6.0
makedist Imported Upstream version 5.6.0
makerpm Imported Upstream version 5.6.0
missing Imported Upstream version 5.6.0
mkinstalldirs Imported Upstream version 5.6.0
php.gif Imported Upstream version 5.6.0
php.ini-development Imported Upstream version 5.6.4
php.ini-production Imported Upstream version 5.6.4
php5.spec.in Imported Upstream version 5.6.0
run-tests.php Imported Upstream version 5.6.5
server-tests-config.php Imported Upstream version 5.6.1
server-tests.php Imported Upstream version 5.6.4
snapshot Imported Upstream version 5.6.0
stamp-h.in Imported Upstream version 5.6.0
stub.c Imported Upstream version 5.6.0
vcsclean Imported Upstream version 5.6.0

README.md

The PHP Interpreter

This is the github mirror of the official PHP repository located at http://git.php.net.

Build Status

Pull Requests

PHP accepts pull requests via github. Discussions are done on github, but depending on the topic can also be relayed to the official PHP developer mailinglist internals@lists.php.net.

New features require an RFC and must be accepted by the developers. See https://wiki.php.net/rfc and https://wiki.php.net/rfc/voting for more information on the process.

Bug fixes do not require an RFC, but require a bugtracker ticket. Always open a ticket at https://bugs.php.net and reference the bug id using #NNNNNN.

Fix #55371: get_magic_quotes_gpc() throws deprecation warning

After removing magic quotes, the get_magic_quotes_gpc function caused
a deprecate warning. get_magic_quotes_gpc can be used to detected
the magic_quotes behavior and therefore should not raise a warning at any
time. The patch removes this warning

We do not merge pull requests directly on github. All PRs will be pulled and pushed through http://git.php.net.

Guidelines for contributors

Something went wrong with that request. Please try again.