Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP
The gPodder podcast client, versions 2.x (two branch) and 3.x (master branch).
Python QML JavaScript Makefile Groff HTML CSS
Tag: harmattan/gpod…

Fetching latest commit…

Cannot retrieve the latest commit at this time

Failed to load latest commit information.
.tx
bin
data
debian
draft
examples
src
tools
COPYING
MANIFEST.in
README
makefile
setup.py

README

                          ___         _    _           ____
                     __ _| _ \___  __| |__| |___ _ _  |__ /
                    / _` |  _/ _ \/ _` / _` / -_) '_|  |_ \
                    \__, |_| \___/\__,_\__,_\___|_|   |___/
                    |___/
                          Media aggregator and podcast client

  ............................................................................

             Copyright  2005-2011 Thomas Perl and the gPodder Team


 [ LICENSE ]

    gPodder is free software; you can redistribute it and/or modify
    it under the terms of the GNU General Public License as published by
    the Free Software Foundation; either version 3 of the License, or
    (at your option) any later version.

    gPodder is distributed in the hope that it will be useful,
    but WITHOUT ANY WARRANTY; without even the implied warranty of
    MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
    GNU General Public License for more details.

    You should have received a copy of the GNU General Public License
    along with this program. If not, see <http://www.gnu.org/licenses/>.



 [ DEPENDENCIES ]

    - Python 2.6 or newer              http://python.org/
    - Feedparser 5.0.1 or newer        http://code.google.com/p/feedparser/
    - mygpoclient 1.4 or newer         http://thp.io/2010/mygpoclient/
    - Python D-Bus bindings

    gPodder is still compatible with Python 2.5, but you might need to
    install sqlite3 and json ("simplejson") manually. We reserve the
    right to drop support for Python 2.5 in future point releases.

    As an alternative to python-dbus on Mac OS X and Windows, you can use
    the dummy (no-op) D-Bus module provided in "tools/fake-dbus-module/".


 [ GTK UI - ADDITIONAL DEPENDENCIES ]

    - PyGTK 2.12 or newer              http://pygtk.org/


 [ QML UI - ADDITIONAL DEPENDENCIES ]

    - Qt 4.7.1 or newer                http://qt.nokia.com/
    - PySide 1.0.8 or newer            http://www.pyside.org/
    - Qt Mobility 1.2 or newer         http://qt.nokia.com/

    The QML UI depends on the QtMultimediaKit QML bindings for playing
    back audio (libdeclarative-multimedia in Debian).


 [ OPTIONAL DEPENDENCIES ]

    - Bluetooth file sending: gnome-obex-send or bluetooth-sendto
    - HTML shownotes: python-webkit
    - Size detection on Windows: PyWin32
    - Native OS X support: ige-mac-integration


 [ BUILD DEPENDENCIES ]

    - help2man
    - intltool


 [ TEST DEPENDENCIES ]

    - python-minimock
    - python-coverage


 [ RUNNING AND INSTALLATION ]

    To run gPodder from source, use "bin/gpodder".

    To install gPodder system-wide, use "make install".


 [ PORTABLE MODE / ROAMING PROFILES ]

    The run-time environment variable GPODDER_HOME is used to set
    the location for storing the database and downloaded files.

    This can be used for multiple configurations or to store the
    download directory directly on a MP3 player or USB disk:

        export GPODDER_HOME=/media/usbdisk/gpodder-data/


 [ MORE INFORMATION ]

    - Homepage                         http://gpodder.org/
    - Bug tracker                      http://bugs.gpodder.org/
    - Mailing list                     http://freelists.org/list/gpodder
    - IRC channel                      #gpodder on irc.freenode.net

  ............................................................................
             Last updated: 2011-11-06 by Thomas Perl <thp.io/about>

Something went wrong with that request. Please try again.