New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

tests: use Test::Requires for optional modules used during testing #4

Merged
merged 2 commits into from Jan 18, 2015

Conversation

Projects
None yet
2 participants
@dolmen

dolmen commented Jan 18, 2015

Use Test::Requires to load optional modules useful for testing and skip tests if they are missing.

The patch may seem huge, but this is only due to indent that had to be fixed in the second commit.

dolmen added some commits Jan 15, 2015

tests: use Test::Requires to simplify code
Use Test::Requires to skip tests that depend on the availability of an
optional module.
tests: indent source code
In t/*.t:
- fix spaces/tabs indent inconsistencies: use only tabs
- fix indent after previous commit (use Test::Requires)

ggl added a commit that referenced this pull request Jan 18, 2015

Merge pull request #4 from dolmen/improve-tests
tests: use Test::Requires for optionnal modules used during testing

@ggl ggl merged commit 313c3ae into gps4net:master Jan 18, 2015

@dolmen

This comment has been minimized.

Show comment
Hide comment
@dolmen

dolmen Jan 19, 2015

Thanks!
By the way, the tag "1.24" is missing in the repo.

dolmen commented Jan 19, 2015

Thanks!
By the way, the tag "1.24" is missing in the repo.

@ggl

This comment has been minimized.

Show comment
Hide comment
@ggl

ggl Jan 19, 2015

Well, this is going to be 1.25.

ggl commented Jan 19, 2015

Well, this is going to be 1.25.

@dolmen

This comment has been minimized.

Show comment
Hide comment
@dolmen

dolmen Jan 19, 2015

Well, this is going to be 1.25.

Yes, but the last release is 1.24. But the last tag is 1.23.
You have to either create the 1.24 tag that is missing, or just to push it with git push --tags.

dolmen commented Jan 19, 2015

Well, this is going to be 1.25.

Yes, but the last release is 1.24. But the last tag is 1.23.
You have to either create the 1.24 tag that is missing, or just to push it with git push --tags.

@dolmen dolmen changed the title from tests: use Test::Requires for optionnal modules used during testing to tests: use Test::Requires for optional modules used during testing Jan 19, 2015

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment