Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Gradle Module Metadata compatibility for unique snapshots #11050

Closed
ljacomet opened this issue Oct 15, 2019 · 3 comments
Closed

Gradle Module Metadata compatibility for unique snapshots #11050

ljacomet opened this issue Oct 15, 2019 · 3 comments
Assignees
Milestone

Comments

@ljacomet
Copy link
Member

@ljacomet ljacomet commented Oct 15, 2019

Gradle Module Metadata publication of Maven unique snapshots has been broken for a while, and only work by accident, but not always (#9462).

Unfortunately, the proper publication result, an upcoming change in Gradle 6.0, makes it impossible to resolve with Gradle 5.6 and lower.

So we should have at least one version in the 5.x line that can resolve this metadata to help users affected by the issue.

@ljacomet ljacomet added this to the 5.6.3 milestone Oct 15, 2019
@ljacomet ljacomet self-assigned this Oct 15, 2019
ljacomet added a commit that referenced this issue Oct 16, 2019
This fix will enable Gradle 5.6.3 to consume Gradle Module Metadata for
-SNAPSHOT produced by Gradle 6+

Fixes #11050
@ljacomet
Copy link
Member Author

@ljacomet ljacomet commented Oct 17, 2019

This is now merged - closing

@ljacomet
Copy link
Member Author

@ljacomet ljacomet commented Oct 22, 2019

Sadly issues still exist in 5.6.3.

@ljacomet ljacomet reopened this Oct 22, 2019
ljacomet added a commit that referenced this issue Oct 22, 2019
* Properly saves the timestamp information in the metadata cache
* Properly considers snapshots as changing modules

Fixes #11050
@ljacomet
Copy link
Member Author

@ljacomet ljacomet commented Oct 22, 2019

Because of other issues, Gradle 6.0 metadata format will not be automatically consumed by Gradle 5.3 - 5.6.
Given this, no more attempts will be made to improve the snapshot compatibility.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
Development

No branches or pull requests

1 participant