Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Using dependency declaration gradleKotlinDsl() fails with 5.5 #9919

Closed
eskatos opened this issue Jul 10, 2019 · 1 comment
Closed

Using dependency declaration gradleKotlinDsl() fails with 5.5 #9919

eskatos opened this issue Jul 10, 2019 · 1 comment
Assignees
Milestone

Comments

@eskatos
Copy link
Member

@eskatos eskatos commented Jul 10, 2019

Expected Behavior

The following should work:

dependencies {
    compileOnly(gradleKotlinDsl())
}

Current Behavior

Starting with Gradle 5.5 the following throws:

dependencies {
    compileOnly(gradleKotlinDsl())
}
* Where:
Build file 'build.gradle.kts' line: 2

* What went wrong:
Build_gradle cannot be cast to org.gradle.api.internal.project.ProjectInternal

Context

Gradle 5.4.1 works, 5.5 fails

Regression introduced by 3bb8bc8#diff-dac0155eeffb0b2c9c91ddd6741c6b11R70

Steps to Reproduce

See above

Your Environment

Build scan URL: https://scans.gradle.com/s/yb7rov7qsyz56/failure?openFailures=WzBd&openStackTraces=WzBd#top=0

@eskatos eskatos added this to the 5.5.1 milestone Jul 10, 2019
@eskatos eskatos self-assigned this Jul 10, 2019
eskatos added a commit that referenced this issue Jul 10, 2019
Signed-off-by: Paul Merlin <paul@gradle.com>
eskatos added a commit that referenced this issue Jul 10, 2019
Signed-off-by: Paul Merlin <paul@gradle.com>
@eskatos
Copy link
Member Author

@eskatos eskatos commented Jul 10, 2019

Fixed in #9920, will be in Gradle 5.5.1

@eskatos eskatos closed this as completed Jul 10, 2019
@big-guy big-guy changed the title Dependency declaration on gradleKotlinDsl() throws with 5.5 Using dependency declaration gradleKotlinDsl() fails with 5.5 Jul 10, 2019
big-guy added a commit that referenced this issue Jul 10, 2019
* origin/release:
  Allow running build types for multiple subprojects at once
  Fix kotlin-dsl regression #9919
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
Development

No branches or pull requests

2 participants