Skip to content
Compare
Choose a tag to compare

5.5.1

@big-guy big-guy released this
· 28018 commits to release since this release
3245f74
Compare
Choose a tag to compare

This bug-fix release contains three changes to Gradle 5.5:

  • Combination of errorprone-gradle-plugin and options.fork = true causes Java compilation to fail in Gradle 5.5 #9897
  • Using dependency declaration gradleKotlinDsl() fails with 5.5 #9919
  • Chain of transitives aligned by same platform can lead to broken resolution #9882

We recommend that you use Gradle 5.5.1 over 5.5.

Upgrade Instructions

Switch your build to use Gradle 5.5.1 by updating your wrapper properties:

./gradlew wrapper --gradle-version=5.5.1

Standalone downloads are available at https://gradle.org/install.

Reporting Problems

If you find a problem with Gradle, please file a bug on GitHub Issues adhering to our issue guidelines. If you're not sure you're encountering a bug, please use the forum.