Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP
Browse files

dom4j is needed in 1.3 but crashes 2.0, so added version check

  • Loading branch information...
commit e5de6f5d0b7d1479a611ae0513eb1b68062075ec 1 parent b86a5a7
Burt Beckwith authored
Showing with 7 additions and 3 deletions.
  1. +7 −3 grails-app/conf/BuildConfig.groovy
View
10 grails-app/conf/BuildConfig.groovy
@@ -1,3 +1,5 @@
+import grails.util.Metadata
+
grails.project.work.dir = 'target'
grails.project.docs.output.dir = 'docs/manual' // for backwards-compatibility, the docs are checked into gh-pages branch
@@ -17,8 +19,8 @@ grails.project.dependency.resolution = {
dependencies {
compile('org.springframework.security:spring-security-core:3.0.7.RELEASE') {
// transitive = false
- excludes 'spring-expression', 'spring-core', 'spring-context', 'spring-tx',
- 'spring-aop', 'spring-jdbc', 'spring-web', 'spring-test', 'aspectjrt',
+ excludes 'spring-expression', 'spring-core', 'spring-context', 'spring-tx',
+ 'spring-aop', 'spring-jdbc', 'spring-web', 'spring-test', 'aspectjrt',
'aspectjweaver', 'cglib-nodep', 'ehcache', 'commons-collections',
'hsqldb', 'jsr250-api', 'log4j', 'junit', 'mockito-core', 'jmock-junit4'
}
@@ -36,7 +38,9 @@ grails.project.dependency.resolution = {
build(":hibernate:$grailsVersion") {
export = false
- excludes 'dom4j'
+ if (Metadata.current.getGrailsVersion()[0] != '1') {
+ excludes 'dom4j'
+ }
}
// hackish using 'provided' but 'build' doesn't put it in the pom
Please sign in to comment.
Something went wrong with that request. Please try again.