Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP
Browse files

GPSPRINGSECURITYUI-8 removed explicit dependencies and changed to jus…

…t being documented
  • Loading branch information...
commit d5e03787880af5138a9b1027430cd6548655593d 1 parent b590eba
Burt Beckwith authored
View
24 SpringSecurityUiGrailsPlugin.groovy
@@ -20,13 +20,7 @@ import org.codehaus.groovy.grails.plugins.springsecurity.SpringSecurityUtils
class SpringSecurityUiGrailsPlugin {
String version = '0.1.3'
- String grailsVersion = '1.2.2 > *'
- Map dependsOn = [springSecurityCore: '0.4 > *',
- mail: '0.9 > *',
- jquery: '1.4.2.5 > *',
- jqueryUi: '1.8.2.3 > *',
- famfamfam: '1.0 > *']
-
+ String grailsVersion = '1.3 > *'
List pluginExcludes = [
'docs/**',
'src/docs/**',
@@ -37,16 +31,14 @@ class SpringSecurityUiGrailsPlugin {
String author = 'Burt Beckwith'
String authorEmail = 'beckwithb@vmware.com'
- String title = 'User interface extensions for the Spring Security plugin.'
- String description = 'User interface extensions for the Spring Security plugin.'
+ String title = 'Spring Security UI'
+ String description = 'User interface extensions for the Spring Security plugin'
String documentation = 'http://grails.org/plugin/spring-security-ui'
String license = 'APACHE'
- def organization = [ name: 'SpringSource', url: 'http://www.springsource.org/' ]
- def developers = [
- [ name: 'Burt Beckwith', email: 'beckwithb@vmware.com' ] ]
- def issueManagement = [ system: 'JIRA', url: 'http://jira.grails.org/browse/GPSPRINGSECURITYUI' ]
- def scm = [ url: 'https://github.com/grails-plugins/grails-spring-security-ui/' ]
+ def organization = [name: 'SpringSource', url: 'http://www.springsource.org/']
+ def issueManagement = [system: 'JIRA', url: 'http://jira.grails.org/browse/GPSPRINGSECURITYUI']
+ def scm = [url: 'https://github.com/grails-plugins/grails-spring-security-ui/']
def doWithSpring = {
@@ -55,8 +47,10 @@ class SpringSecurityUiGrailsPlugin {
return
}
- println 'Configuring Spring Security UI ...'
+ println '\nConfiguring Spring Security UI ...'
SpringSecurityUtils.loadSecondaryConfig 'DefaultUiSecurityConfig'
+
+ println '... finished configuring Spring Security UI\n'
}
}
View
20 application.properties
@@ -1,13 +1,9 @@
-#Grails Metadata file
-#Sun Sep 11 00:51:21 EDT 2011
-app.grails.version=2.0.0.M1
-app.name=spring-security-ui
-plugins.famfamfam=1.0
-plugins.functional-test=1.2.7
-plugins.hibernate=2.0.0.M1
-plugins.jquery=1.4.2.5
-plugins.jquery-ui=1.8.2.3
-plugins.mail=0.9
+app.grails.version=2.0.0
+plugins.famfamfam=1.0.1
+plugins.hibernate=2.0.0
+plugins.jquery=1.7.1
+plugins.jquery-ui=1.8.15
+plugins.mail=1.0
+plugins.release=1.0.1
plugins.spring-security-acl=1.1
-plugins.spring-security-core=1.2.1
-plugins.tomcat=2.0.0.M1
+plugins.spring-security-core=1.2.7.2
View
18 grails-app/conf/BuildConfig.groovy
@@ -1,12 +1,9 @@
-grails.project.class.dir = 'target/classes'
-grails.project.test.class.dir = 'target/test-classes'
-grails.project.test.reports.dir = 'target/test-reports'
+grails.project.work.dir = 'target'
grails.project.docs.output.dir = 'docs/manual' // for backwards-compatibility, the docs are checked into gh-pages branch
grails.project.dependency.resolution = {
inherits 'global'
-
log 'warn'
repositories {
@@ -14,13 +11,16 @@ grails.project.dependency.resolution = {
grailsHome()
grailsCentral()
+ mavenLocal()
mavenCentral()
mavenRepo 'http://download.java.net/maven/2/'
}
- plugins {
- build(':release:1.0.0.RC3') {
- export = false
- }
- }
+// plugins {
+// compile ':spring-security-core:1.2.7.2'
+// compile ':mail:1.0'
+// compile ':jquery:1.7.1'
+// compile ':jquery-ui:1.8.15'
+// compile ':famfamfam:1.0.1'
+// }
}
View
13 scripts/_Install.groovy
@@ -0,0 +1,13 @@
+println '''
+*******************************************************
+* You've installed the Spring Security UI plugin . *
+* *
+* Make sure you have the following plugins installed: *
+* spring-security-core (1.2+) *
+* mail (1.0+) *
+* jquery (1.4.4+) *
+* jquery-ui (1.8.7+) *
+* famfamfam (1.0+) *
+* *
+*******************************************************
+'''
Please sign in to comment.
Something went wrong with that request. Please try again.