Skip to content
This repository

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Newer
Older
100644 176 lines (137 sloc) 7.171 kb
7995c9f2 » graemerocher
2012-06-19 ignoring test temporarily, as due to infrastructure issues it is not …
1 The following libraries are included in Grails because they are required either for building the framework or for running the command line tools or for running Grails applications themselves.
2
3 * ant.jar, ant-junit.jar, ant-launcher.jar, ant-trax.jar
4 - Ant 1.8.2 (http://ant.apache.org) Apache 2.0 License
5 - used to build the framework and for the command line tools (Gant)
6 - required for running Grails applications when using AntBuilder
7
8 * antlr-2.7.7.jar
9 - ANTLR 2.7.7 (http://www.antlr.org) BSD License
10 - required for running Grails applications (Hibernate)
11
12 * aspectjrt-1.6.8.jar, aspectjweaver-1.6.8.jar
13 - AspectJ 1.6.8 (http://www.eclipse.org/aspectj/) Eclipse Public License (EPL)
14 - required for running Grails applications
15
16 * cglib-nodep-2.1_3.jar
17 - CGLIB 2.1_3 with ObjectWeb ASM 1.5.3 (http://cglib.sourceforge.net) Apache 1.1 License
18 - required for running Grails applications (Spring AOP & Hibernate)
19
20 * concurrentlinkedhashmap-lru-1.0_jdk5.jar
21 - ConcurrentLinkedHashMap policy: least-recently-used, jdk: 5 (https://code.google.com/p/concurrentlinkedhashmap) Apache License 2.0
22 - required for building Grails core
23 - required for running Grails applications
24
25 * commons-beanutils-1.8.0.jar
26 - Commons BeanUtils 1.8.0 (http://commons.apache.org/beanutils/) Apache 2.0 License
27 - required for running Grails applications
28
29 * commons-codec-1.4.jar
30 - Commons Codec 1.4 (http://commons.apache.org/codec/) Apache 2.0 License
31 - required for running Grails applications
32
33 * commons-cli-1.0.jar
34 - Commons CLI 1.0 (http://commons.apache.org/cli/) Apache 2.0 License
35 - required for the command line tools (Gant)
36
37 * commons-collections-3.2.1.jar
38 - Commons Collections 3.2.1 (http://commons.apache.org/collections/) Apache 2.0 License
39 - required for building Grails core
40 - required for running Grails applications
41
42 * commons-dbcp-1.3.jar
43 - Commons DBCP 1.3 (http://commons.apache.org/dbcp/) Apache 2.0 License
44 - required for building Grails core
45 - required for running Grails applications
46
47 * commons-el-1.0.jar
48 - Commons Expression Language 1.0 (http://commons.apache.org/el/) Apache 2.0 License
49 - required for running Grails applications
50
51 * commons-fileupload-1.2.1.jar
52 - Commons File Upload 1.2.1 (http://commons.apache.org/fileupload/) Apache 2.0 License
53 - required for running Grails applications (When using file uploads)
54
55 * commons-io-1.4.jar
56 - Commons I/O 1.4 (http://commons.apache.org/io/) Apache 2.0 License
57 - required for running Grails applications
58
59 * commons-lang-2.4.jar
60 - Commons Lang 2.4 (http://commons.apache.org/lang/) Apache 2.0 License
61 - required for building Grails core
62 - required for running Grails application
63
64 * commons-pool-1.5.5.jar
65 - Commons Pool 1.5.5 (http://commons.apache.org/pool/) Apache 2.0 License
66 - required for running Grails applications
67
68 * commons-validator-1.3.1.jar
69 - Commons Validator 1.3.1 (http://commons.apache.org/validator/) Apache 2.0 License
70 - required for building Grails core
71 - required for running Grails applications
72
73 * dom4j-1.6.1.jar
74 - Dom4J 1.6.1 (http://dom4j.org/) BSD Style License (see http://www.dom4j.org/license.html)
75 - required for building Grails core
76 - required for running Grails applications
77
78 * ejb3-persistence-1.0.2.GA.jar
79 - EJB 3.0 Final Release
80 - required for running Grails applications (When using Hibernate EJB3 annotations)
81
82 * ehcache-1.5.0.jar
83 - EHCache 1.5.0 (http://ehcache.sourceforge.net/) Apache 2.0 License
84 - required if you want to use EHCache as your second-level cache
85 - optional otherwise
86
87 * gant_groovy1.8-1.9.5.jar
88 - Gant 1.9.5 (http://gant.codehaus.org) Apache 2.0 License
89 - required for the command line tools (Gant)
90
1abc370c » bobbywarner
2012-09-10 Updated 2.1 branch with Groovy 1.8.8
91 * groovy-all-1.8.8.jar
92 - Groovy 1.8.8 (http://groovy.codehaus.org) Apache 2.0 License
7995c9f2 » graemerocher
2012-06-19 ignoring test temporarily, as due to infrastructure issues it is not …
93 - required for the command line tools (Gant)
94 - required for building Grails core
95 - required for running Grails applications
96
97 * hibernate-commons-annotations-3.2.0.Final.jar
98 - Hibernate Annotations 3.2.0 GA (http://annotations.hibernate.org) LGPL License
99 - required for running Grails applications (When using Hibernate EJB3 annotations)
100
101 * hibernate-core-3.6.10.Final.jar
102 - Hibernate 3.6.8 GA (http://www.hibernate.org) LGPL License
103 - required for building Grails core
104 - required for running Grails applications
105
106 * hsqldb-1.8.0.10.jar
107 - HSQLDB 1.8.0.10 (http://hsqldb.org/) HSQLDB License (see http://hsqldb.org/web/hsqlLicense.html)
108 - required for building Grails core
109 - required for running Grails applications (With an in-memory database)
110
111 * h2-1.3.164.jar
112 - H2 1.3.164 (http://www.h2database.com/) H2 License (see http://www.h2database.com/html/license.html)
113 - required for building Grails core
114 - required for running Grails applications (With an in-memory database)
115
116 * javassist-3.12.0.GA.jar
117 - Javassist 3.12.0 (http://www.jboss.org/javassist/) MPL or LGPL License
118 - required for running Grails applications
119
120 * jline-0.9.94.jar
121 - JLine 0.9.94 (http://jline.sourceforge.net/)
122 - required for the Grails shell
123
124 * jsp-api-2.1.jar
125 - Java Server Pages 2.1 Spec
126 - required for building Grails core
127 - required for running Grails applications
128
129 * jta-1.1.jar
130 - Java Transaction API
131 - required for running Grails applications
132
133 * junit-4.8.1.jar
134 - JUnit 4.8.1 (http://junit.org) CPL 1.0 License
135 - required for building Grails core
136 - required for the command line tools (Gant)
137
138 * log4j-1.2.16.jar
139 - Log4J 1.2.16 (http://logging.apache.org/log4j/) Apache 2.0 License
140 - required for running Grails applications
141
142 * ognl-2.7.3.jar
143 - OGNL 2.7.3 (http://www.ognl.org/) OGNL License (http://www.ognl.org/copyright.html)
144 - required for running Grails applications (When using Web Flows)
145
146 * oro-2.0.8.jar
147 - Jakarta ORO 2.0.8 (http://jakarta.apache.org/oro/) Apache 2.0 License
148 - required for running Grails applications
149
150 * protobuf-java-2.4.1.jar
151 - Google's language-neutral, platform-neutral, extensible mechanism or serializing structured data
152
153 * sitemesh-2.4.jar
154 - Sitemesh 2.4 (http://www.opensymphony.com/sitemesh) OpenSymphony Software License (see http://www.opensymphony.com/sitemesh/license.action)
155 - required for building Grails core
156 - required for running Grails applications
157
158 * slf4j-api-1.5.6.jar, slf4j-log4j12-1.5.6.jar
159 - Simple Logging Facade for Java 1.5.6 (http://www.slf4j.org/) MIT License (http://www.slf4j.org/license.html)
160 - required for building Grails core
161 - required for running Grails applications
162
163 * org.springframework.*.jar
4c1c0d4d » jeffbrown
2013-01-23 Upgrade to Spring 3.1.4
164 - Spring Framework 3.1.4.RELEASE (http://www.springframework.org) Apache 2.0 License
7995c9f2 » graemerocher
2012-06-19 ignoring test temporarily, as due to infrastructure issues it is not …
165 - required for building Grails core
166 - required for the command line tools (Gant)
167 - required for running Grails applications
168
169 * org.springframework.webflow-2.0.8.RELEASE.jar, org.springframework.binding-2.0.8.RELEASE.jar, org.springframework.js-2.0.8.RELEASE.jar
170 - Spring Web Flow 2.0.8 (http://www.springframework.org) Apache 2.0 License
171 - required for building Grails core
172 - required for running Grails applications (When using Web flows)
173
174 * xpp3_min-1.1.3.4.O.jar
175 - XML Pull Parser (XPP) 1.1.3.4.O (http://www.extreme.indiana.edu/xgws/xsoap/xpp/) Indiana University Extreme! Lab Software License (see http://www.extreme.indiana.edu/viewcvs/~checkout~/XPP3/java/LICENSE.txt)
176 - required for running Grails applications (dependency of XStream 1.2.1)
177
Something went wrong with that request. Please try again.