Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP
Newer
Older
100644 174 lines (134 sloc) 6.982 kB
3e17890 1.1 branch is now trunk
graeme authored
1 The following libraries are included in Grails because they are required either for building the framework or for running the command line tools or for running Grails applications themselves.
2
3 * ant.jar, ant-nodeps.jar, ant-junit.jar, ant-launcher.jar, ant-trax.jar
4423ade @graemerocher fix for GRAILS-4751 "Upgraded some key dependencies". Also removed OS…
graemerocher authored
4 - Ant 1.7.1 (http://ant.apache.org) Apache 2.0 License
3e17890 1.1 branch is now trunk
graeme authored
5 - used to build the framework and for the command line tools (Gant)
6 - required for running Grails applications when using AntBuilder
7
8 * antlr-2.7.6.jar
9 - ANTLR 2.7.6 (http://www.antlr.org) BSD License
10 - required for running Grails applications (Hibernate)
11
5f867a1 @graemerocher Upgrade to Spring 3.0.2 and AspectJ 1.6.8
graemerocher authored
12 * aspectjrt-1.6.8.jar, aspectjweaver-1.6.8.jar
13 - AspectJ 1.6.8 (http://www.eclipse.org/aspectj/) Eclipse Public License (EPL)
4423ade @graemerocher fix for GRAILS-4751 "Upgraded some key dependencies". Also removed OS…
graemerocher authored
14 - required for running Grails applications
15
3e17890 1.1 branch is now trunk
graeme authored
16 * cglib-nodep-2.1_3.jar
17 - CGLIB 2.1_3 with ObjectWeb ASM 1.5.3 (http://cglib.sourceforge.net) Apache 1.1 License
18 - required for running Grails applications (Spring AOP & Hibernate)
19
f6d9fbe GRAILS-6622 - Updated concurrent linked hashmap dependency to be jdk …
Marco Vermeulen authored
20 * concurrentlinkedhashmap-lru-1.0_jdk5.jar
21 - ConcurrentLinkedHashMap policy: least-recently-used, jdk: 5 (https://code.google.com/p/concurrentlinkedhashmap) Apache License 2.0
55cf993 GRAILS-6622 - Introduced ConcurrentLinkedHashMap to solve memory leak…
Marco Vermeulen authored
22 - required for building Grails core
23 - required for running Grails applications
24
4423ade @graemerocher fix for GRAILS-4751 "Upgraded some key dependencies". Also removed OS…
graemerocher authored
25 * commons-beanutils-1.8.0.jar
26 - Commons BeanUtils 1.8.0 (http://commons.apache.org/beanutils/) Apache 2.0 License
3e17890 1.1 branch is now trunk
graeme authored
27 - required for running Grails applications
28
0e5f091 @burtbeckwith GRAILS-6784 and GRAILS-5978 - updated commons-codec, commons-pool, an…
burtbeckwith authored
29 * commons-codec-1.4.jar
30 - Commons Codec 1.4 (http://commons.apache.org/codec/) Apache 2.0 License
3e17890 1.1 branch is now trunk
graeme authored
31 - required for running Grails applications
32
33 * commons-cli-1.0.jar
34 - Commons CLI 1.0 (http://commons.apache.org/cli/) Apache 2.0 License
35 - required for the command line tools (Gant)
36
4423ade @graemerocher fix for GRAILS-4751 "Upgraded some key dependencies". Also removed OS…
graemerocher authored
37 * commons-collections-3.2.1.jar
38 - Commons Collections 3.2.1 (http://commons.apache.org/collections/) Apache 2.0 License
3e17890 1.1 branch is now trunk
graeme authored
39 - required for building Grails core
40 - required for running Grails applications
41
0e5f091 @burtbeckwith GRAILS-6784 and GRAILS-5978 - updated commons-codec, commons-pool, an…
burtbeckwith authored
42 * commons-dbcp-1.3.jar
43 - Commons DBCP 1.3 (http://commons.apache.org/dbcp/) Apache 2.0 License
3e17890 1.1 branch is now trunk
graeme authored
44 - required for building Grails core
45 - required for running Grails applications
46
47 * commons-el-1.0.jar
48 - Commons Expression Language 1.0 (http://commons.apache.org/el/) Apache 2.0 License
49 - required for running Grails applications
50
741b78f @graemerocher upgrade to commons fileupload 1.2.1 (GRAILS-4098)
graemerocher authored
51 * commons-fileupload-1.2.1.jar
52 - Commons File Upload 1.2.1 (http://commons.apache.org/fileupload/) Apache 2.0 License
3e17890 1.1 branch is now trunk
graeme authored
53 - required for running Grails applications (When using file uploads)
54
55 * commons-io-1.4.jar
56 - Commons I/O 1.4 (http://commons.apache.org/io/) Apache 2.0 License
57 - required for running Grails applications
58
59 * commons-lang-2.4.jar
60 - Commons Lang 2.4 (http://commons.apache.org/lang/) Apache 2.0 License
61 - required for building Grails core
62 - required for running Grails application
63
0e5f091 @burtbeckwith GRAILS-6784 and GRAILS-5978 - updated commons-codec, commons-pool, an…
burtbeckwith authored
64 * commons-pool-1.5.5.jar
65 - Commons Pool 1.5.5 (http://commons.apache.org/pool/) Apache 2.0 License
3e17890 1.1 branch is now trunk
graeme authored
66 - required for running Grails applications
67
4423ade @graemerocher fix for GRAILS-4751 "Upgraded some key dependencies". Also removed OS…
graemerocher authored
68 * commons-validator-1.3.1.jar
69 - Commons Validator 1.3.1 (http://commons.apache.org/validator/) Apache 2.0 License
3e17890 1.1 branch is now trunk
graeme authored
70 - required for building Grails core
71 - required for running Grails applications
72
73 * dom4j-1.6.1.jar
74 - Dom4J 1.6.1 (http://dom4j.org/) BSD Style License (see http://www.dom4j.org/license.html)
75 - required for building Grails core
76 - required for running Grails applications
77
4423ade @graemerocher fix for GRAILS-4751 "Upgraded some key dependencies". Also removed OS…
graemerocher authored
78 * ejb3-persistence-1.0.2.GA.jar
3e17890 1.1 branch is now trunk
graeme authored
79 - EJB 3.0 Final Release
80 - required for running Grails applications (When using Hibernate EJB3 annotations)
81
82 * ehcache-1.5.0.jar
83 - EHCache 1.5.0 (http://ehcache.sourceforge.net/) Apache 2.0 License
84 - required if you want to use EHCache as your second-level cache
85 - optional otherwise
86
ae6f3f3 @graemerocher Upgrade to Gant 1.9.2 final
graemerocher authored
87 * gant_groovy1.7-1.9.2.jar
88 - Gant 1.9.2 (http://gant.codehaus.org) Apache 2.0 License
3e17890 1.1 branch is now trunk
graeme authored
89 - required for the command line tools (Gant)
90
de6137a @jeffbrown Downgrade to Groovy 1.7.5
jeffbrown authored
91 * groovy-all-1.7.5.jar
92 - Groovy 1.7.5 (http://groovy.codehaus.org) Apache 2.0 License
3e17890 1.1 branch is now trunk
graeme authored
93 - required for the command line tools (Gant)
94 - required for building Grails core
95 - required for running Grails applications
96
97 * hibernate-annotations.jar, hibernate-commons-annotations.jar
4423ade @graemerocher fix for GRAILS-4751 "Upgraded some key dependencies". Also removed OS…
graemerocher authored
98 - Hibernate Annotations 3.4.0 GA (http://annotations.hibernate.org) LGPL License
3e17890 1.1 branch is now trunk
graeme authored
99 - required for running Grails applications (When using Hibernate EJB3 annotations)
100
101 * hibernate3.jar
102 - Hibernate 3.3.1 GA (http://www.hibernate.org) LGPL License
103 - required for building Grails core
104 - required for running Grails applications
105
4423ade @graemerocher fix for GRAILS-4751 "Upgraded some key dependencies". Also removed OS…
graemerocher authored
106 * hsqldb-1.8.0.10.jar
107 - HSQLDB 1.8.0.10 (http://hsqldb.org/) HSQLDB License (see http://hsqldb.org/web/hsqlLicense.html)
3e17890 1.1 branch is now trunk
graeme authored
108 - required for building Grails core
109 - required for running Grails applications (With an in-memory database)
110
4423ade @graemerocher fix for GRAILS-4751 "Upgraded some key dependencies". Also removed OS…
graemerocher authored
111 * javassist-3.8.0.GA.jar
112 - Javassist 3.8 (http://www.jboss.org/javassist/) MPL or LGPL License
3e17890 1.1 branch is now trunk
graeme authored
113 - required for running Grails applications
114
ac73208 @jeffbrown GRAILS-6300 - Upgrade jline to 0.9.94
jeffbrown authored
115 * jline-0.9.94.jar
116 - JLine 0.9.94 (http://jline.sourceforge.net/)
3e17890 1.1 branch is now trunk
graeme authored
117 - required for the Grails shell
118
119 * jsp-api-2.1.jar
120 - Java Server Pages 2.1 Spec
121 - required for building Grails core
122 - required for running Grails applications
123
4423ade @graemerocher fix for GRAILS-4751 "Upgraded some key dependencies". Also removed OS…
graemerocher authored
124 * jta-1.1.jar
3e17890 1.1 branch is now trunk
graeme authored
125 - Java Transaction API
126 - required for running Grails applications
127
8a6d774 @alkemist GRAILS-3237 - Replace JUnit 3 with JUnit 4.
alkemist authored
128 * junit-4.8.1.jar
129 - JUnit 4.8.1 (http://junit.org) CPL 1.0 License
3e17890 1.1 branch is now trunk
graeme authored
130 - required for building Grails core
131 - required for the command line tools (Gant)
132
af181a3 @burtbeckwith GRAILS-6638 updated Log4j to 1.2.16
burtbeckwith authored
133 * log4j-1.2.16.jar
134 - Log4J 1.2.16 (http://logging.apache.org/log4j/) Apache 2.0 License
3e17890 1.1 branch is now trunk
graeme authored
135 - required for running Grails applications
136
4423ade @graemerocher fix for GRAILS-4751 "Upgraded some key dependencies". Also removed OS…
graemerocher authored
137 * ognl-2.7.3.jar
138 - OGNL 2.7.3 (http://www.ognl.org/) OGNL License (http://www.ognl.org/copyright.html)
3e17890 1.1 branch is now trunk
graeme authored
139 - required for running Grails applications (When using Web Flows)
140
141 * oro-2.0.8.jar
142 - Jakarta ORO 2.0.8 (http://jakarta.apache.org/oro/) Apache 2.0 License
143 - required for running Grails applications
144
145 * sitemesh-2.4.jar
146 - Sitemesh 2.4 (http://www.opensymphony.com/sitemesh) OpenSymphony Software License (see http://www.opensymphony.com/sitemesh/license.action)
147 - required for building Grails core
148 - required for running Grails applications
149
150 * slf4j-api-1.5.6.jar, slf4j-log4j12-1.5.6.jar
151 - Simple Logging Facade for Java 1.5.6 (http://www.slf4j.org/) MIT License (http://www.slf4j.org/license.html)
152 - required for building Grails core
153 - required for running Grails applications
154
b06d4e0 @graemerocher upgrade to Spring 3 RC3 and fix for GRAILS-4589
graemerocher authored
155 * org.springframework.*.jar
8335759 @burtbeckwith GRAILS-6991 - updated to Spring 3.0.5
burtbeckwith authored
156 - Spring Framework 3.0.5 (http://www.springframework.org) Apache 2.0 License
3e17890 1.1 branch is now trunk
graeme authored
157 - required for building Grails core
158 - required for the command line tools (Gant)
159 - required for running Grails applications
160
b06d4e0 @graemerocher upgrade to Spring 3 RC3 and fix for GRAILS-4589
graemerocher authored
161 * org.springframework.webflow-2.0.8.RELEASE.jar, org.springframework.binding-2.0.8.RELEASE.jar, org.springframework.js-2.0.8.RELEASE.jar
162 - Spring Web Flow 2.0.8 (http://www.springframework.org) Apache 2.0 License
3e17890 1.1 branch is now trunk
graeme authored
163 - required for building Grails core
164 - required for running Grails applications (When using Web flows)
165
25a597e @graemerocher upgrade to svnkit 1.3.1
graemerocher authored
166 * svnkit-1.3.1.jar
167 - SVNKit 1.3.1 (http://svnkit.com/) TMate Open Source License (see http://svnkit.com/license.html)
3e17890 1.1 branch is now trunk
graeme authored
168 - required for the command line tools (Gant)
169
170 * xpp3_min-1.1.3.4.O.jar
171 - XML Pull Parser (XPP) 1.1.3.4.O (http://www.extreme.indiana.edu/xgws/xsoap/xpp/) Indiana University Extreme! Lab Software License (see http://www.extreme.indiana.edu/viewcvs/~checkout~/XPP3/java/LICENSE.txt)
172 - required for running Grails applications (dependency of XStream 1.2.1)
173
Something went wrong with that request. Please try again.