Skip to content
Newer
Older
100644 169 lines (130 sloc) 6.57 KB
3e17890 1.1 branch is now trunk
graeme authored
1 The following libraries are included in Grails because they are required either for building the framework or for running the command line tools or for running Grails applications themselves.
2
3 * ant.jar, ant-nodeps.jar, ant-junit.jar, ant-launcher.jar, ant-trax.jar
4423ade @graemerocher fix for GRAILS-4751 "Upgraded some key dependencies". Also removed OS…
graemerocher authored
4 - Ant 1.7.1 (http://ant.apache.org) Apache 2.0 License
3e17890 1.1 branch is now trunk
graeme authored
5 - used to build the framework and for the command line tools (Gant)
6 - required for running Grails applications when using AntBuilder
7
8 * antlr-2.7.6.jar
9 - ANTLR 2.7.6 (http://www.antlr.org) BSD License
10 - required for running Grails applications (Hibernate)
11
5f867a1 @graemerocher Upgrade to Spring 3.0.2 and AspectJ 1.6.8
graemerocher authored
12 * aspectjrt-1.6.8.jar, aspectjweaver-1.6.8.jar
13 - AspectJ 1.6.8 (http://www.eclipse.org/aspectj/) Eclipse Public License (EPL)
4423ade @graemerocher fix for GRAILS-4751 "Upgraded some key dependencies". Also removed OS…
graemerocher authored
14 - required for running Grails applications
15
3e17890 1.1 branch is now trunk
graeme authored
16 * cglib-nodep-2.1_3.jar
17 - CGLIB 2.1_3 with ObjectWeb ASM 1.5.3 (http://cglib.sourceforge.net) Apache 1.1 License
18 - required for running Grails applications (Spring AOP & Hibernate)
19
4423ade @graemerocher fix for GRAILS-4751 "Upgraded some key dependencies". Also removed OS…
graemerocher authored
20 * commons-beanutils-1.8.0.jar
21 - Commons BeanUtils 1.8.0 (http://commons.apache.org/beanutils/) Apache 2.0 License
3e17890 1.1 branch is now trunk
graeme authored
22 - required for running Grails applications
23
24 * commons-codec-1.3.jar
25 - Commons Codec 1.3 (http://commons.apache.org/codec/) Apache 2.0 License
26 - required for running Grails applications
27
28 * commons-cli-1.0.jar
29 - Commons CLI 1.0 (http://commons.apache.org/cli/) Apache 2.0 License
30 - required for the command line tools (Gant)
31
4423ade @graemerocher fix for GRAILS-4751 "Upgraded some key dependencies". Also removed OS…
graemerocher authored
32 * commons-collections-3.2.1.jar
33 - Commons Collections 3.2.1 (http://commons.apache.org/collections/) Apache 2.0 License
3e17890 1.1 branch is now trunk
graeme authored
34 - required for building Grails core
35 - required for running Grails applications
36
4423ade @graemerocher fix for GRAILS-4751 "Upgraded some key dependencies". Also removed OS…
graemerocher authored
37 * commons-dbcp-1.2.2.jar
38 - Commons DBCP 1.2.2 (http://commons.apache.org/dbcp/) Apache 2.0 License
3e17890 1.1 branch is now trunk
graeme authored
39 - required for building Grails core
40 - required for running Grails applications
41
42 * commons-el-1.0.jar
43 - Commons Expression Language 1.0 (http://commons.apache.org/el/) Apache 2.0 License
44 - required for running Grails applications
45
741b78f @graemerocher upgrade to commons fileupload 1.2.1 (GRAILS-4098)
graemerocher authored
46 * commons-fileupload-1.2.1.jar
47 - Commons File Upload 1.2.1 (http://commons.apache.org/fileupload/) Apache 2.0 License
3e17890 1.1 branch is now trunk
graeme authored
48 - required for running Grails applications (When using file uploads)
49
50 * commons-io-1.4.jar
51 - Commons I/O 1.4 (http://commons.apache.org/io/) Apache 2.0 License
52 - required for running Grails applications
53
54 * commons-lang-2.4.jar
55 - Commons Lang 2.4 (http://commons.apache.org/lang/) Apache 2.0 License
56 - required for building Grails core
57 - required for running Grails application
58
4423ade @graemerocher fix for GRAILS-4751 "Upgraded some key dependencies". Also removed OS…
graemerocher authored
59 * commons-pool-1.5.3.jar
60 - Commons Pool 1.5.3 (http://commons.apache.org/pool/) Apache 2.0 License
3e17890 1.1 branch is now trunk
graeme authored
61 - required for running Grails applications
62
4423ade @graemerocher fix for GRAILS-4751 "Upgraded some key dependencies". Also removed OS…
graemerocher authored
63 * commons-validator-1.3.1.jar
64 - Commons Validator 1.3.1 (http://commons.apache.org/validator/) Apache 2.0 License
3e17890 1.1 branch is now trunk
graeme authored
65 - required for building Grails core
66 - required for running Grails applications
67
68 * dom4j-1.6.1.jar
69 - Dom4J 1.6.1 (http://dom4j.org/) BSD Style License (see http://www.dom4j.org/license.html)
70 - required for building Grails core
71 - required for running Grails applications
72
4423ade @graemerocher fix for GRAILS-4751 "Upgraded some key dependencies". Also removed OS…
graemerocher authored
73 * ejb3-persistence-1.0.2.GA.jar
3e17890 1.1 branch is now trunk
graeme authored
74 - EJB 3.0 Final Release
75 - required for running Grails applications (When using Hibernate EJB3 annotations)
76
77 * ehcache-1.5.0.jar
78 - EHCache 1.5.0 (http://ehcache.sourceforge.net/) Apache 2.0 License
79 - required if you want to use EHCache as your second-level cache
80 - optional otherwise
81
ae6f3f3 @graemerocher Upgrade to Gant 1.9.2 final
graemerocher authored
82 * gant_groovy1.7-1.9.2.jar
83 - Gant 1.9.2 (http://gant.codehaus.org) Apache 2.0 License
3e17890 1.1 branch is now trunk
graeme authored
84 - required for the command line tools (Gant)
85
57266cd @jeffbrown GRAILS-6577 - upgrade to Groovy 1.7.4
jeffbrown authored
86 * groovy-all-1.7.4.jar
87 - Groovy 1.7.4 (http://groovy.codehaus.org) Apache 2.0 License
3e17890 1.1 branch is now trunk
graeme authored
88 - required for the command line tools (Gant)
89 - required for building Grails core
90 - required for running Grails applications
91
92 * hibernate-annotations.jar, hibernate-commons-annotations.jar
4423ade @graemerocher fix for GRAILS-4751 "Upgraded some key dependencies". Also removed OS…
graemerocher authored
93 - Hibernate Annotations 3.4.0 GA (http://annotations.hibernate.org) LGPL License
3e17890 1.1 branch is now trunk
graeme authored
94 - required for running Grails applications (When using Hibernate EJB3 annotations)
95
96 * hibernate3.jar
97 - Hibernate 3.3.1 GA (http://www.hibernate.org) LGPL License
98 - required for building Grails core
99 - required for running Grails applications
100
4423ade @graemerocher fix for GRAILS-4751 "Upgraded some key dependencies". Also removed OS…
graemerocher authored
101 * hsqldb-1.8.0.10.jar
102 - HSQLDB 1.8.0.10 (http://hsqldb.org/) HSQLDB License (see http://hsqldb.org/web/hsqlLicense.html)
3e17890 1.1 branch is now trunk
graeme authored
103 - required for building Grails core
104 - required for running Grails applications (With an in-memory database)
105
4423ade @graemerocher fix for GRAILS-4751 "Upgraded some key dependencies". Also removed OS…
graemerocher authored
106 * javassist-3.8.0.GA.jar
107 - Javassist 3.8 (http://www.jboss.org/javassist/) MPL or LGPL License
3e17890 1.1 branch is now trunk
graeme authored
108 - required for running Grails applications
109
ac73208 @jeffbrown GRAILS-6300 - Upgrade jline to 0.9.94
jeffbrown authored
110 * jline-0.9.94.jar
111 - JLine 0.9.94 (http://jline.sourceforge.net/)
3e17890 1.1 branch is now trunk
graeme authored
112 - required for the Grails shell
113
114 * jsp-api-2.1.jar
115 - Java Server Pages 2.1 Spec
116 - required for building Grails core
117 - required for running Grails applications
118
4423ade @graemerocher fix for GRAILS-4751 "Upgraded some key dependencies". Also removed OS…
graemerocher authored
119 * jta-1.1.jar
3e17890 1.1 branch is now trunk
graeme authored
120 - Java Transaction API
121 - required for running Grails applications
122
8a6d774 @alkemist GRAILS-3237 - Replace JUnit 3 with JUnit 4.
alkemist authored
123 * junit-4.8.1.jar
124 - JUnit 4.8.1 (http://junit.org) CPL 1.0 License
3e17890 1.1 branch is now trunk
graeme authored
125 - required for building Grails core
126 - required for the command line tools (Gant)
127
af181a3 @burtbeckwith GRAILS-6638 updated Log4j to 1.2.16
burtbeckwith authored
128 * log4j-1.2.16.jar
129 - Log4J 1.2.16 (http://logging.apache.org/log4j/) Apache 2.0 License
3e17890 1.1 branch is now trunk
graeme authored
130 - required for running Grails applications
131
4423ade @graemerocher fix for GRAILS-4751 "Upgraded some key dependencies". Also removed OS…
graemerocher authored
132 * ognl-2.7.3.jar
133 - OGNL 2.7.3 (http://www.ognl.org/) OGNL License (http://www.ognl.org/copyright.html)
3e17890 1.1 branch is now trunk
graeme authored
134 - required for running Grails applications (When using Web Flows)
135
136 * oro-2.0.8.jar
137 - Jakarta ORO 2.0.8 (http://jakarta.apache.org/oro/) Apache 2.0 License
138 - required for running Grails applications
139
140 * sitemesh-2.4.jar
141 - Sitemesh 2.4 (http://www.opensymphony.com/sitemesh) OpenSymphony Software License (see http://www.opensymphony.com/sitemesh/license.action)
142 - required for building Grails core
143 - required for running Grails applications
144
145 * slf4j-api-1.5.6.jar, slf4j-log4j12-1.5.6.jar
146 - Simple Logging Facade for Java 1.5.6 (http://www.slf4j.org/) MIT License (http://www.slf4j.org/license.html)
147 - required for building Grails core
148 - required for running Grails applications
149
b06d4e0 @graemerocher upgrade to Spring 3 RC3 and fix for GRAILS-4589
graemerocher authored
150 * org.springframework.*.jar
c10697a @jeffbrown GRAILS-6357 - upgrade to Spring 3.0.3
jeffbrown authored
151 - Spring Framework 3.0.3 (http://www.springframework.org) Apache 2.0 License
3e17890 1.1 branch is now trunk
graeme authored
152 - required for building Grails core
153 - required for the command line tools (Gant)
154 - required for running Grails applications
155
b06d4e0 @graemerocher upgrade to Spring 3 RC3 and fix for GRAILS-4589
graemerocher authored
156 * org.springframework.webflow-2.0.8.RELEASE.jar, org.springframework.binding-2.0.8.RELEASE.jar, org.springframework.js-2.0.8.RELEASE.jar
157 - Spring Web Flow 2.0.8 (http://www.springframework.org) Apache 2.0 License
3e17890 1.1 branch is now trunk
graeme authored
158 - required for building Grails core
159 - required for running Grails applications (When using Web flows)
160
25a597e @graemerocher upgrade to svnkit 1.3.1
graemerocher authored
161 * svnkit-1.3.1.jar
162 - SVNKit 1.3.1 (http://svnkit.com/) TMate Open Source License (see http://svnkit.com/license.html)
3e17890 1.1 branch is now trunk
graeme authored
163 - required for the command line tools (Gant)
164
165 * xpp3_min-1.1.3.4.O.jar
166 - XML Pull Parser (XPP) 1.1.3.4.O (http://www.extreme.indiana.edu/xgws/xsoap/xpp/) Indiana University Extreme! Lab Software License (see http://www.extreme.indiana.edu/viewcvs/~checkout~/XPP3/java/LICENSE.txt)
167 - required for running Grails applications (dependency of XStream 1.2.1)
168
Something went wrong with that request. Please try again.