Skip to content
Browse files

upgrade to ant 1.8.2 and remove ant-nodeps

  • Loading branch information...
1 parent 88c9ac3 commit 6e6725a28ae6753bd0f8dae066754cb9fd97f043 @jeffbrown jeffbrown committed Apr 28, 2011
View
5 build.gradle
@@ -13,7 +13,8 @@ buildscript {
apply plugin: 'idea'
grailsVersion = '1.4.0.BUILD-SNAPSHOT'
-antVersion = "1.8.1"
+antVersion = "1.8.2"
+antNodepsVersion = "1.8.1"
antTraxVersion = "1.7.1"
springVersion = "3.0.5.RELEASE"
ivyVersion = "2.2.0"
@@ -50,7 +51,7 @@ subprojects { project ->
"Built-By": System.properties['user.name'],
"Created-By": System.properties['java.vm.version'] + " (" + System.properties['java.vm.vendor'] + ")",
"Implementation-Title": "Grails",
- "Ant-Version": 'Apache Ant 1.8.1', // todo we just have this property to make it easy to compare manifests. Remove it when this build is life
+ "Ant-Version": 'Apache Ant 1.8.2', // todo we just have this property to make it easy to compare manifests. Remove it when this build is life
"Implementation-Version": grailsVersion,
"Implementation-Vendor": 'grails.org')
View
2 build.properties
@@ -15,7 +15,7 @@ bundlor.servlet.jsp.version=2.1.0
bundlor.radeox.version=1.0.0.b2
bundlor.groovy.version=1.8.0.rc-1
bundlor.spring.version=3.0.5.RELEASE
-bundlor.ant.version=1.8.1
+bundlor.ant.version=1.8.2
bundlor.ivy.version=2.0.0
bundlor.gant.version=1.9.2
bundlor.junit.version=4.8.1
View
4 dependencies.txt
@@ -1,7 +1,7 @@
The following libraries are included in Grails because they are required either for building the framework or for running the command line tools or for running Grails applications themselves.
-* ant.jar, ant-nodeps.jar, ant-junit.jar, ant-launcher.jar, ant-trax.jar
-- Ant 1.8.1 (http://ant.apache.org) Apache 2.0 License
+* ant.jar, ant-junit.jar, ant-launcher.jar, ant-trax.jar
+- Ant 1.8.2 (http://ant.apache.org) Apache 2.0 License
- used to build the framework and for the command line tools (Gant)
- required for running Grails applications when using AntBuilder
View
1 grails-bootstrap/build.gradle
@@ -23,7 +23,6 @@ dependencies {
compile "org.apache.ant:ant:${antVersion}",
"org.apache.ant:ant-launcher:${antVersion}",
"org.apache.ant:ant-junit:${antVersion}",
- "org.apache.ant:ant-nodeps:${antVersion}",
"org.apache.ant:ant-trax:${antTraxVersion}",
"org.apache.ivy:ivy:${ivyVersion}",
'org.codehaus.gant:gant_groovy1.7:1.9.3'
View
7 ...-bootstrap/src/main/groovy/org/codehaus/groovy/grails/resolve/GrailsCoreDependencies.java
@@ -89,10 +89,9 @@ public Object doCall() {
ModuleRevisionId.newInstance("org.bouncycastle", "bcpg-jdk15", "1.45"),
ModuleRevisionId.newInstance("org.bouncycastle", "bcprov-jdk15", "1.45"),
ModuleRevisionId.newInstance("org.tmatesoft.svnkit", "svnkit", "1.3.4"),
- ModuleRevisionId.newInstance("org.apache.ant", "ant", "1.8.1"),
- ModuleRevisionId.newInstance("org.apache.ant", "ant-launcher", "1.8.1"),
- ModuleRevisionId.newInstance("org.apache.ant", "ant-junit", "1.8.1"),
- ModuleRevisionId.newInstance("org.apache.ant", "ant-nodeps", "1.8.1"),
+ ModuleRevisionId.newInstance("org.apache.ant", "ant", "1.8.2"),
+ ModuleRevisionId.newInstance("org.apache.ant", "ant-launcher", "1.8.2"),
+ ModuleRevisionId.newInstance("org.apache.ant", "ant-junit", "1.8.2"),
ModuleRevisionId.newInstance("org.apache.ant", "ant-trax", "1.7.1"),
ModuleRevisionId.newInstance("jline", "jline", "0.9.94"),
ModuleRevisionId.newInstance("org.fusesource.jansi", "jansi", "1.2.1"),
View
1 grails-scripts/build.gradle
@@ -5,7 +5,6 @@ dependencies {
compile "org.apache.ant:ant:${antVersion}",
"org.apache.ant:ant-launcher:${antVersion}",
"org.apache.ant:ant-junit:${antVersion}",
- "org.apache.ant:ant-nodeps:${antVersion}",
"org.apache.ant:ant-trax:${antTraxVersion}",
"org.apache.ivy:ivy:2.2.0",
'org.codehaus.gant:gant_groovy1.7:1.9.3'
View
5 ...-uber/src/test/groovy/org/codehaus/groovy/grails/resolve/IvyDependencyManagerTests.groovy
@@ -750,7 +750,7 @@ class IvyDependencyManagerTests extends GroovyTestCase {
ModuleRevisionId entry = orgDeps.find { ModuleRevisionId rev -> rev.name == 'ant-junit'}
assertEquals "org.apache.ant", entry.organisation
assertEquals "ant-junit", entry.name
- assertEquals "1.8.1", entry.revision
+ assertEquals "1.8.2", entry.revision
def resolvers = manager.chainResolver.resolvers
assertEquals 6, resolvers.size()
@@ -820,8 +820,7 @@ class IvyDependencyManagerTests extends GroovyTestCase {
dependencies {
build "org.tmatesoft.svnkit:svnkit:1.2.0",
- "org.apache.ant:ant-junit:1.8.1",
- "org.apache.ant:ant-nodeps:1.8.1",
+ "org.apache.ant:ant-junit:1.8.2",
"org.apache.ant:ant-trax:1.7.1",
"org.grails:grails-radeox:1.0-b4",
"com.h2database:h2:1.2.144",
View
4 maven/grails-bootstrap.pom.in
@@ -91,14 +91,14 @@
<dependency>
<groupId>org.apache.ant</groupId>
<artifactId>ant</artifactId>
- <version>1.8.1</version>
+ <version>1.8.2</version>
<scope>compile</scope>
</dependency>
<dependency>
<groupId>org.apache.ant</groupId>
<artifactId>ant-launcher</artifactId>
- <version>1.8.1</version>
+ <version>1.8.2</version>
<scope>compile</scope>
</dependency>
View
11 maven/grails-core.pom.in
@@ -36,21 +36,14 @@
<dependency>
<groupId>org.apache.ant</groupId>
<artifactId>ant</artifactId>
- <version>1.8.1</version>
+ <version>1.8.2</version>
<optional>true</optional>
</dependency>
<dependency>
<groupId>org.apache.ant</groupId>
<artifactId>ant-junit</artifactId>
- <version>1.8.1</version>
- <optional>true</optional>
- </dependency>
-
- <dependency>
- <groupId>org.apache.ant</groupId>
- <artifactId>ant-nodeps</artifactId>
- <version>1.8.1</version>
+ <version>1.8.2</version>
<optional>true</optional>
</dependency>
View
2 maven/grails-docs.pom.in
@@ -70,7 +70,7 @@
<dependency>
<groupId>org.apache.ant</groupId>
<artifactId>ant</artifactId>
- <version>1.8.1</version>
+ <version>1.8.2</version>
</dependency>
<!-- for PDF doc generation -->
View
9 maven/grails-scripts.pom.in
@@ -89,14 +89,7 @@
<dependency>
<groupId>org.apache.ant</groupId>
<artifactId>ant-junit</artifactId>
- <version>1.8.1</version>
- <scope>runtime</scope>
- </dependency>
-
- <dependency>
- <groupId>org.apache.ant</groupId>
- <artifactId>ant-nodeps</artifactId>
- <version>1.8.1</version>
+ <version>1.8.2</version>
<scope>runtime</scope>
</dependency>

0 comments on commit 6e6725a

Please sign in to comment.
Something went wrong with that request. Please try again.