Permalink
Browse files

GRAILS-6638 updated Log4j to 1.2.16

  • Loading branch information...
1 parent 902092c commit af181a3c356771b819db12cff866d06ce65d9d12 @burtbeckwith burtbeckwith committed Aug 23, 2010
View
2 .classpath
@@ -30,7 +30,7 @@
<classpathentry kind="lib" path="lib/jstl-1.1.2.jar"/>
<classpathentry kind="lib" path="lib/jta-1.1.jar"/>
<classpathentry kind="lib" path="lib/junit-4.8.1.jar"/>
- <classpathentry kind="lib" path="lib/log4j-1.2.15.jar"/>
+ <classpathentry kind="lib" path="lib/log4j-1.2.16.jar"/>
<classpathentry kind="lib" path="lib/ognl-2.7.3.jar"/>
<classpathentry kind="lib" path="lib/oro-2.0.8.jar"/>
<classpathentry kind="lib" path="lib/serializer-2.7.1.jar"/>
View
2 build.properties
@@ -7,7 +7,7 @@ grails.src.groovy=src/groovy
bundlor.javax.persistence.version=1.0.2.GA
bundlor.webflow.version=2.0.8
bundlor.xpp.version=1.1.3
-bundlor.log4j.version=1.2.15
+bundlor.log4j.version=1.2.16
bundlor.sitemesh.version=2.4.0
bundlor.hibernate.version=3.3.1.GA
bundlor.javassist.version=3.9.0
View
4 dependencies.txt
@@ -125,8 +125,8 @@ The following libraries are included in Grails because they are required either
- required for building Grails core
- required for the command line tools (Gant)
-* log4j-1.2.15.jar
-- Log4J 1.2.15 (http://logging.apache.org/log4j/) Apache 2.0 License
+* log4j-1.2.16.jar
+- Log4J 1.2.16 (http://logging.apache.org/log4j/) Apache 2.0 License
- required for running Grails applications
* ognl-2.7.3.jar
View
2 grails.ipr
@@ -481,7 +481,7 @@
<root url="jar://$PROJECT_DIR$/lib/commons-el-1.0.jar!/" />
<root url="jar://$PROJECT_DIR$/lib/commons-cli-1.0.jar!/" />
<root url="jar://$PROJECT_DIR$/lib/oro-2.0.8.jar!/" />
- <root url="jar://$PROJECT_DIR$/lib/log4j-1.2.15.jar!/" />
+ <root url="jar://$PROJECT_DIR$/lib/log4j-1.2.16.jar!/" />
<root url="jar://$PROJECT_DIR$/lib/commons-io-1.4.jar!/" />
<root url="jar://$PROJECT_DIR$/lib/commons-codec-1.3.jar!/" />
<root url="jar://$PROJECT_DIR$/lib/commons-lang-2.4.jar!/" />
View
BIN lib/log4j-1.2.15.jar
Binary file not shown.
View
BIN lib/log4j-1.2.16.jar
Binary file not shown.
View
2 src/java/org/codehaus/groovy/grails/resolve/IvyDependencyManager.groovy
@@ -315,7 +315,7 @@ class IvyDependencyManager extends AbstractIvyDependencyManager implements Depen
}
// logging
- "${runtimeDependenciesMethod}"("log4j:log4j:1.2.15",
+ "${runtimeDependenciesMethod}"("log4j:log4j:1.2.16",
"org.slf4j:jcl-over-slf4j:1.5.8",
"org.slf4j:jul-to-slf4j:1.5.8",
"org.slf4j:slf4j-log4j12:1.5.8" ) {
View
2 src/test/org/codehaus/groovy/grails/resolve/IvyDependencyManagerTests.groovy
@@ -722,7 +722,7 @@ class IvyDependencyManagerTests extends GroovyTestCase {
"commons-io:commons-io:1.4",
"commons-lang:commons-lang:2.4",
"javax.transaction:jta:1.1",
- "log4j:log4j:1.2.15",
+ "log4j:log4j:1.2.16",
"net.sf.ehcache:ehcache:1.6.1",
"opensymphony:oscache:2.4.1",
"opensymphony:sitemesh:2.4",

2 comments on commit af181a3

@dmarley

I just downloaded 1.3.4 and it looks like 1.2.15 is in the /lib dir

@burtbeckwith
grails member

Right, this is for http://jira.codehaus.org/browse/GRAILS-6638 which is going into 1.3.5

Please sign in to comment.