Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP

Loading…

Upgraded JUnit Version #292

Merged
merged 1 commit into from

4 participants

@bobbywarner
Collaborator

No description provided.

@lhotari
Owner

In some projects I've had problem in having 2 different junit versions on the classpath. Those problems have been fixed by including also junit:junit-dep as a dependency besides junit:junit . In 4.11 junit:junit-dep relocates to junit:junit . Could you check if there is a proper solution to this problem (2 different versions of junit on the classpath). I think spock has a dependency to junit-dep .

@bobbywarner
Collaborator

@lhotari Sure, I'll look into it.

@graemerocher graemerocher merged commit aa59c20 into grails:master
@jeffbrown
Owner

I think this commit caused a couple of the JavascriptTagLibTests to start failing. They were passing by accident before. This may help: 3b648bb

@lhotari
Owner

Bobby, junit version in master is 4.10 . Could you take a look at upgrading it? Please add a dependency to junit:junit-dep to prevent 2 versions of junit on the classpath. In 4.11 junit:junit-dep relocates to junit:junit . I think spock has a dependency to junit-dep and therefore this is a common problem.

@bobbywarner bobbywarner referenced this pull request
Closed

Updated Junit to 4.11 #340

@bobbywarner
Collaborator

@lhotari Looks like Spock actually removed the dependency to junit-dep (spockframework/spock@fb46cfc). So, I just updated junit to 4.11 and ran the test suite and everything passed. Submitted as pull request #340

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Commits on Nov 28, 2012
  1. @bobbywarner

    Upgraded JUnit Version

    bobbywarner authored
This page is out of date. Refresh to see the latest.
View
2  build.gradle
@@ -42,7 +42,7 @@ ext {
springWebflowVersion= "2.0.8.RELEASE"
hibernateVersion = "3.6.10.Final"
ehcacheVersion = "2.4.6"
- junitVersion = "4.10"
+ junitVersion = "4.11"
concurrentlinkedhashmapVersion = "1.2_jdk5"
}
View
2  grails-bootstrap/src/main/groovy/org/codehaus/groovy/grails/resolve/GrailsCoreDependencies.java
@@ -113,7 +113,7 @@ public Object doCall() {
String antVersion = "1.8.4";
String slf4jVersion = "1.7.2";
- String junitVersion = "4.10";
+ String junitVersion = "4.11";
ModuleRevisionId[] buildDependencies = {
ModuleRevisionId.newInstance("org.springframework.uaa", "org.springframework.uaa.client", "1.0.1.RELEASE"),
ModuleRevisionId.newInstance("com.google.protobuf", "protobuf-java", "2.4.1"),
Something went wrong with that request. Please try again.