Skip to content

@lhotari lhotari released this Mar 24, 2015 · 4518 commits to master since this release

Update Notes

Recommended plugin versions

If you are upgrading from previous versions and you use the hibernate4 plugin, you will need to update the version in BuildConfig:

runtime ':hibernate4:4.3.8.1' // or ':hibernate:3.6.10.19'

recommended tomcat, asset-pipeline, cache and scaffolding plugin versions for Grails 2.4.x :

build ':tomcat:7.0.55.2'
compile ':cache:1.1.8'
compile ':scaffolding:2.1.2'
compile ':asset-pipeline:2.1.5'

If you are using MongoDb GORM, the recommended plugin version is 3.0.3

compile ':mongodb:3.0.3'

Changes in ehcache version in hibernate plugins

The ehcache version in hibernate plugins has been upgrade to 2.9.0 version of ehcache.
With this version, the defaults for hibernate.cache.region.factory_class have been changed.
New defaults in DataSource.groovy are

//    cache.region.factory_class = 'org.hibernate.cache.SingletonEhCacheRegionFactory' // Hibernate 3
    cache.region.factory_class = 'org.hibernate.cache.ehcache.SingletonEhCacheRegionFactory' // Hibernate 4

This change is required for applications that use multiple datasources and have the Hibernate caching enabled.

There might be other changes in ehcache behaviour and configuration since it has been upgraded from 2.4.8 to 2.9.0 version.

ehcache 2.9.0 is more strict about the configuration. ehcache is used in the spring-security-core plugin for caching users. There is a problem reported as GRAILS-12120.
As a workaround to the "net.sf.ehcache.CacheException: Another unnamed CacheManager already exists in the same VM." error you can add this config to Config.groovy:

beans {
   cacheManager {
      shared = true
  }
}

hibernate.flush.mode has been fixed

There has been a bug that hibernate.flush.mode setting wasn't used for all locations. Grails 2.4.3 changed the default to "manual", but that setting wasn't used everywhere.
GRAILS-11687 jira issue contains more information about the fixed bug.
This is mentioned in the release notes since some application might be relying on the previous behaviour.

h2 version change

This release ships with com.h2database:h2 version 1.3.176. This version has issues opening files created by previous versions, ref http://osdir.com/ml/h2-database/2014-06/msg00007.html .
The workaround is use a newer/older version of h2.

    dependencies {
        runtime 'com.h2database:h2:1.3.175'   // or 'com.h2database:h2:1.4.186' for most recent
    }

Docs download

Assets 3
You can’t perform that action at this time.