Permalink
Browse files

GRAILS-6774 Update log4j to latest stable version (1.2.16) for maven …

…archetype

Exclusions for jmxtools, jmxri, jms and mail are not needed anymore, as they are marked as optional dependencies for log4j 1.2.16
  • Loading branch information...
1 parent ad7029a commit b203a4cf241b7b23da988e3f8606f4fc9916577e @rlovtangen rlovtangen committed Sep 30, 2010
Showing with 11 additions and 31 deletions.
  1. +11 −31 src/main/resources/archetype-resources/pom.xml
@@ -203,12 +203,6 @@
<artifactId>slf4j-log4j12</artifactId>
<version>1.5.8</version>
<scope>runtime</scope>
- <exclusions>
- <exclusion>
- <artifactId>log4j</artifactId>
- <groupId>log4j</groupId>
- </exclusion>
- </exclusions>
</dependency>
<!-- Needed in the case of AOP usage -->
@@ -224,31 +218,6 @@
<version>1.6.8</version>
</dependency>
- <dependency>
- <groupId>log4j</groupId>
- <artifactId>log4j</artifactId>
- <version>1.2.15</version>
- <scope>runtime</scope>
- <exclusions>
- <exclusion>
- <groupId>com.sun.jdmk</groupId>
- <artifactId>jmxtools</artifactId>
- </exclusion>
- <exclusion>
- <groupId>com.sun.jmx</groupId>
- <artifactId>jmxri</artifactId>
- </exclusion>
- <exclusion>
- <groupId>javax.jms</groupId>
- <artifactId>jms</artifactId>
- </exclusion>
- <exclusion>
- <groupId>javax.mail</groupId>
- <artifactId>mail</artifactId>
- </exclusion>
- </exclusions>
- </dependency>
-
<dependency>
<groupId>commons-codec</groupId>
<artifactId>commons-codec</artifactId>
@@ -269,6 +238,17 @@
</dependencies>
+ <dependencyManagement>
+ <dependencies>
+ <dependency>
+ <groupId>log4j</groupId>
+ <artifactId>log4j</artifactId>
+ <version>1.2.16</version>
+ <scope>runtime</scope>
+ </dependency>
+ </dependencies>
+ </dependencyManagement>
+
<repositories>
<!-- Required to get hold of javassist:javassist -->
<repository>

0 comments on commit b203a4c

Please sign in to comment.