Permalink
Commits on Feb 11, 2010
  1. remove .gitignore file

    jeffbrown committed Feb 11, 2010
Commits on Feb 10, 2010
  1. GRAILS-5767 - the json and rico builders are coded to throw IllegalAr…

    …gumentException when invalid methods are invoked in builder code. with Groovy 1.6 an InvokerInvocationException was being thrown from the reflection API. With Groovy 1.7 the IllegalArgumentException thrown by the builders is showing up, which I think is the right thing, pending confirmation.
    jeffbrown committed Feb 10, 2010
Commits on Feb 9, 2010
  1. GRAILS-5767 - improve Groovy 1.7 support. this particular change is r…

    …elated to the last argument to a constructor being a closure and looking like an anonymous inner class
    jeffbrown committed Feb 9, 2010
  2. GRAILS-5767 - improve Groovy 1.7 support. this particular change is r…

    …elated to the last argument to a constructor being a closure and looking like an anonymous inner class
    jeffbrown committed Feb 9, 2010
  3. GRAILS-5767 - improve Groovy 1.7 support. this particular change is r…

    …elated to the last argument to a constructor being a closure and looking like an anonymous inner class
    jeffbrown committed Feb 9, 2010
  4. fix classpath

    jeffbrown committed Feb 9, 2010
Commits on Feb 8, 2010
  1. The plugin wasn't working on Mac OS X because that platform doesn't have

    a tools.jar file. I should have realised that there was a good reason the
    Maven plugin doesn't fail if tools.jar isn't found. Now the plugin simply
    logs a warning message if tools.jar can't be found and the platform is
    *not* Mac OS X.
    pledbrook committed Feb 8, 2010
  2. I have added an "init" task to the Gradle plugin that creates a fresh

    Grails project. The build file must contain a project version.
    
    The name of the Grails project is set by default to the name of the
    project directory, but this can be overridden with the "args" project
    property:
    
      gradle init -Pargs="my-grails"
    pledbrook committed Feb 8, 2010
Commits on Feb 6, 2010
  1. Upgraded from GParallelizer 0.8.3 to GPars 0.9. Two reasons:

     1. The GParallilizer name and project are deprecated.
     2. GPars is available in Maven Central, whereas GParallelizer
        is in the java.net repository.
    pledbrook committed Feb 6, 2010
Commits on Feb 5, 2010
  1. Configured plugin dependencies to refer to the zip artifact (otherwis…

    …e the ivy resolver tried to resovle JARs instead of plugin zips) and added support for specifying grails repositories in BuildConfig.groovy
    graemerocher committed Feb 5, 2010
  2. updated maven publisher plugin to attach the plugin.xml file to the p…

    …ublished maven artifact
    graemerocher committed Feb 5, 2010
Commits on Feb 4, 2010
  1. inserted missing "new"

    Dierk committed with jeffbrown Feb 4, 2010
  2. maven publisher plugin for Grails that allows deploying Grails war fi…

    …les and Grails plugins into a Maven repository
    graemerocher committed Feb 4, 2010
Commits on Feb 3, 2010
Commits on Feb 2, 2010
  1. Fixed typos in Gradle build.

    pledbrook committed Feb 2, 2010
Commits on Feb 1, 2010
  1. Another fix for GRAILS-5802 "Upgrade Javassist to 3.9" (since javassi…

    …st 3.11 is not OSGi compatible yet, have to use 3.9 as the OSGi version)
    graemerocher committed Feb 1, 2010