New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Use dartfmt for dart/flutter #13

Closed
wants to merge 1 commit into
base: master
from

Conversation

Projects
None yet
2 participants
@passsy
Member

passsy commented Nov 7, 2017

Delegate dart formatting to dartfmt instead of the intellij formatting.

Use dartfmt for dart
Delegate dart formatting to dartfmt instead of the intellij formatting.
@StefMa

This comment has been minimized.

Show comment
Hide comment
@StefMa

StefMa Nov 7, 2017

Member

How can I test this?

Member

StefMa commented Nov 7, 2017

How can I test this?

@passsy

This comment has been minimized.

Show comment
Hide comment
@passsy

passsy Nov 7, 2017

Member

Use IntelliJ and install the dart plugin. Then create a dart project. Alternatively you could create a flutter project.

Then write code, and reformat it as usual

Member

passsy commented Nov 7, 2017

Use IntelliJ and install the dart plugin. Then create a dart project. Alternatively you could create a flutter project.

Then write code, and reformat it as usual

@passsy

This comment has been minimized.

Show comment
Hide comment
@passsy

passsy Nov 20, 2017

Member

It's already the default starting with IntelliJ 2017.3 flutter/flutter-intellij#1108

Member

passsy commented Nov 20, 2017

It's already the default starting with IntelliJ 2017.3 flutter/flutter-intellij#1108

@passsy passsy closed this Nov 20, 2017

@passsy passsy deleted the dart_flutter_formatting branch Nov 21, 2017

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment