Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP
Browse files

tag v3.0

  • Loading branch information...
commit d0fb9a6974046f4cdfb7ea459fcd4c65c45a8c15 1 parent 084743b
@willnorris willnorris authored
Showing with 14 additions and 21 deletions.
  1. +1 −1  admin_panels.php
  2. +1 −1  openid.php
  3. +4 −4 readme.txt
  4. +8 −15 wp-login.php
View
2  admin_panels.php
@@ -592,7 +592,7 @@ function openid_printSystemStatus() {
if (function_exists('xrds_meta')) {
$status[] = array( 'XRDS-Simple', 'info', 'XRDS-Simple plugin is installed.');
} else {
- $status[] = array( 'XRDS-Simple', false, '<a href="http://diso.googlecode.com/svn/wordpress/wp-xrds-simple/branches/refactoring/">XRDS-Simple</a> plugin is not installed. Some features may not work properly (including providing OpenIDs).');
+ $status[] = array( 'XRDS-Simple', false, '<a href="http://wordpress.org/extend/plugins/xrds-simple/">XRDS-Simple</a> plugin is not installed. Some features may not work properly (including providing OpenIDs).');
}
$openid_enabled = openid_enabled();
View
2  openid.php
@@ -5,7 +5,7 @@
Description: Allows the use of OpenID for account registration, authentication, and commenting. Also includes an OpenID provider which can turn WordPress author URLs into OpenIDs.
Author: DiSo Development Team
Author URI: http://diso-project.org/
- Version: trunk
+ Version: 3.0
License: Dual GPL (http://www.fsf.org/licensing/licenses/info/GPLv2.html) and Modified BSD (http://www.fsf.org/licensing/licenses/index_html#ModifiedBSD)
*/
View
8 readme.txt
@@ -3,7 +3,7 @@ Contributors: wnorris, factoryjoe
Tags: openid, authentication
Requires at least: 2.2
Tested up to: 2.6.2
-Stable tag: 2.2.2
+Stable tag: 3.0
Allows WordPress to provide and consumer OpenIDs for authentication of users and comments.
@@ -64,14 +64,14 @@ The easiest way to display the fact that your blog accepts OpenIDs is to enable
the "Comment Form" option for the plugin. This will allow the normal website
field to be used for OpenIDs as well. If this doesn't display properly for
your particular theme or you simply prefer to have a separate OpenID field, you
-can modify your comments.php template to include an "openid_identifier" text field as
+can modify your comments.php template to include an "openid\_identifier" text field as
part of your comment form. For the default theme, this might look like:
<p><input type="text" name="openid_identifier" id="openid_identifier" />
<label for="openid_identifier"><small>OpenID URL</small></label></p>
-The input element MUST have the name "openid\_url". Additionally, using
-"openid\_url" for the id causes the field to be styled with an OpenID logo. To
+The input element MUST have the name "openid\_identifier". Additionally, using
+"openid\_identifier" for the id causes the field to be styled with an OpenID logo. To
remove this, you can override the stylesheet or simply change the element id.
= How do I get help if I have a problem? =
View
23 wp-login.php
@@ -70,16 +70,17 @@ function openid_wp_login_head() {
function openid_wp_login_form() {
global $wp_version;
- $link_class = 'openid_link';
- if ($wp_version < '2.5') { $link_class .= ' legacy'; }
+ echo '<hr id="openid_split" style="clear: both; margin-bottom: 1.5em; border: 0; border-top: 1px solid #999; height: 1px;" />';
- ?>
- <hr />
- <p style="margin-top: 1em;">
- <label><?php printf(__('Or login using your %s url:', 'openid'), '<a class="'.$link_class.'" href="http://openid.net/">'.__('OpenID', 'openid').'</a>') ?><br/>
+ echo '
+ <p>
+ <label style="display: block; margin-bottom: 5px;">' . __('Or login using an OpenID:', 'openid') . '</label>
<input type="text" name="openid_identifier" id="openid_identifier" class="input openid_identifier" value="" size="20" tabindex="25" /></label>
</p>
- <?php
+
+ <p style="font-size: 0.8em;" id="what_is_openid">
+ <a href="http://openid.net/what/" target="_blank">'.__('What is OpenID?', 'openid').'</a>
+ </p>';
}
@@ -91,9 +92,6 @@ function openid_wp_login_form() {
function openid_wp_register_form() {
global $wp_version;
- $link_class = 'openid_link';
- if ($wp_version < '2.5') { $link_class .= ' legacy'; }
-
if (get_option('openid_required_for_registration')) {
$label = __('Register using an OpenID:', 'openid');
echo '
@@ -129,11 +127,6 @@ function openid_wp_register_form() {
<a href="http://openid.net/what/" target="_blank">'.__('What is OpenID?', 'openid').'</a>
</p>';
- /*
- if (!get_option('openid_required_for_registration')) {
- echo '<br style="clear: left;" />';
- }
- */
}
Please sign in to comment.
Something went wrong with that request. Please try again.