Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP
Trivial updates to make ipython-0.10.2 work with jython 2.5.2 on posix

Python Other

This branch is 3 commits ahead, 4 commits behind ipython:0.10.2

Fetching latest commit…

Cannot retrieve the latest commit at this time

Failed to load latest commit information.
IPython
docs
sandbox
scripts
setupext
test
tools
COPYING.txt
MANIFEST.in
README.rst
ipython.py
setup.py
setupbase.py
setupegg.py

README.rst

IPython README

Overview

Welcome to IPython. Our documentation can be found in the docs/source subdirectory. We also have .html and .pdf versions of this documentation available on the IPython website.

Dependencies and supported Python versions

For full details, see the installation section of the manual. The basic parts of IPython only need the Python standard library, but much of its more advanced functionality requires extra packages.

Officially, IPython requires Python version 2.5 or 2.6. We have not yet started to port IPython to Python 3.0.

Warning

IPython 0.10 has only been well tested with Python 2.5 and 2.6. Parts of it may work with Python 2.4, but we do not officially support Python 2.4 anymore. If you need to use 2.4, you can still run IPython 0.9.

IPython 0.10 works with jython 2.5 on Linux/BSD/MacOS/etc with trivial changes available at https://github.com/graphaelli/ijython.
Something went wrong with that request. Please try again.