too many values on x-axis #155

Closed
Finkregh opened this Issue Feb 21, 2013 · 0 comments

Comments

Projects
None yet
2 participants

I have an issue when creating the following graph:

(URI broken apart)

    from: "-1year",
    lineMode: "staircase",
    vtitle: "kW",
    vtitleRight: "m/s",
    xFormat: "%d.%m.%Y",
    target: [
        "alias(secondYAxis(color(transformNull(summarize(foo.foo,'1mon'),0),'%23859900')),'foo')",
        "cactiStyle(alias(alpha(stacked(color(transformNull(summarize(foo.bar,'1mon'),0),'%23268BD2')),0.5),'foo'))",
    ],
    title: "foo"

URI:

/?from=-1year&height=200&until=now&width=1048&template=solarized-light&lineMode=staircase&vtitle=123&vtitleRight=123&xFormat=%d.%m.%Y&target=alias(secondYAxis(color(transformNull(summarize(foo.foo,'1mon'),0),'%23859900')),'foo')&target=cactiStyle(alias(alpha(stacked(color(transformNull(summarize(foo.bar,'1mon'),0),'%23268BD2')),0.5),'foo'))&title=foo&_t=0.2304970659315586

graphite_bug

mleinart added a commit that referenced this issue Mar 15, 2013

Fix missing max interval in xAxisConfigs
Missing max was causing graphs over 1yr with few very points (say,
monthly data) to default to a 12hrly xAxisConfig. Fixes #155

@mleinart mleinart closed this Mar 15, 2013

mleinart added a commit that referenced this issue Mar 15, 2013

Fix missing max interval in xAxisConfigs
Missing max was causing graphs over 1yr with few very points (say,
monthly data) to default to a 12hrly xAxisConfig. Fixes #155
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment