Update source for compatibility with Xcode 5.1.x toolchain and the iOS 7.1 SDK #10

Closed
Anzumana opened this Issue Feb 18, 2014 · 9 comments

Comments

Projects
None yet
3 participants

There seems to be some issues with building the iOS app for iOS 7.1

Hi,
This guy:
http://flyingbanana1024102.wordpress.com/draw-a-graph/

Created a very similar Application.

@Anzumana, Unfortunately, it seems you're the only one with programming skills interested in this project.
Why don't you approach him for collaboration?

Many people need this kind of application.

Thanks for the great suggestion.
Will do so.

@correia correia changed the title from iOS 7.1 to Update source for compatibility with Xcode 5.1.x toolchain and the iOS 7.1 SDK May 17, 2014

@correia correia self-assigned this May 17, 2014

Collaborator

correia commented May 17, 2014

It is my intent to update the master branch so that it builds with Xcode 5.1.x and the iOS 7.1 SDK. I'm currently blocked waiting on an upstream change to the open source Omni Frameworks.

@Anzumana, Any luck with the new guy?

so far he has not responded. :)

What else could be done to attract developers?

I think the best think would be a getting started guide and stuff along those lines.
e.g.
http://openkinect.org/wiki/Main_Page

Collaborator

correia commented May 20, 2014

GraphSketcher-Mac and GraphSketcher-iPad now build with Xcode 5.1 (and in the latter case, agains the iOS 7.1 SDK).

The build system issue has been resolved by the following commits:

commit 391061c
Author: Jim Correia jim.correia@pobox.com
Date: Mon May 19 16:52:12 2014 -0700

Updated GraphSketcher-Mac to build with OmniInspector changes in the updated OmniGroup frameworks.

commit 35afc10
Author: Jim Correia jim.correia@pobox.com
Date: Mon May 19 16:49:57 2014 -0700

Updated the linked frameworks per linkage requirements of updated OmniGroup frameworks.

commit d8bbb92
Author: Jim Correia jim.correia@pobox.com
Date: Mon May 19 16:49:05 2014 -0700

Updated the OmniGroup subproject to 40fbf9d1a0f565be127fc8c8ce3e665da2ea3a4e.

@correia correia closed this May 20, 2014

@correia, When can we expect to be able to download if from the App Store both for OS X and iOS?

Thank You for your work!

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment