Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

[portal] Wrong oauth2 redirect uri #2011

Closed
nicolashenry opened this Issue Mar 6, 2019 · 0 comments

Comments

@nicolashenry
Copy link

nicolashenry commented Mar 6, 2019

Expected Behavior

When using Swagger, the gravitee oauth2 redirect url should work correctly (should be something like https://example.com/portal/swagger-oauth2-redirect.html)

Current Behavior

When using Swagger, there is an error when we trying to use oauth2 security scheme :

Possible Solution

I opened a PR to fix this here.

Steps to Reproduce (for bugs)

  1. Open a swagger page on gravitee on a server with subpath (e.g. https://example.com/portal/)
  2. Click on Authorize (the open api descriptor should have an oauth2 security scheme)
  3. Enter your clientId/clientSecret and click on authorize in the popup
  4. Once logged, see that you have an error page and that you are not logged in gravitee authorization popup

Context

Just trying to use swagger page on gravitee with our oauth2 server.

Your Environment

  • Version used: 1.21.2
  • Browser Name and version: Chrome
  • Operating System and version: Windows 7

@brasseld brasseld self-assigned this Mar 6, 2019

@brasseld brasseld added this to the APIM - 1.23.x milestone Mar 6, 2019

@brasseld brasseld changed the title wrong oauth2 redirect uri [portal] Wrong oauth2 redirect uri Mar 6, 2019

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.