Permalink
Browse files

move author tests into separate directory

  • Loading branch information...
1 parent 6a0d7e5 commit fa232e94cb28c431dba5fb105a015db1205e1bb1 @gray committed Sep 2, 2009
Showing with 42 additions and 22 deletions.
  1. +22 −0 .perlcriticrc
  2. +0 −14 t/99_pod_coverage.t
  3. +0 −4 t/99_kwalitee.t → xt/kwalitee.t
  4. +11 −0 xt/perlcritic.t
  5. +0 −4 t/99_pod.t → xt/pod.t
  6. +9 −0 xt/pod_coverage.t
View
@@ -0,0 +1,22 @@
+verbose = 8
+
+[CodeLayout::ProhibitHardTabs]
+allow_leading_tabs = 0
+severity = 5
+
+[CodeLayout::ProhibitTrailingWhitespace]
+severity = 5
+
+# requires Perl::Critic::More
+[CodeLayout::RequireASCII]
+severity = 5
+
+[TestingAndDebugging::RequireUseWarnings]
+severity = 5
+
+[-TestingAndDebugging::ProhibitNoStrict]
+[-BuiltinFunctions::ProhibitStringyEval]
+
+# requires Regexp::Parser
+[RegularExpressions::ProhibitUnusedCapture]
+severity = 5
View
@@ -1,14 +0,0 @@
-use strict;
-use warnings;
-use Test::More;
-
-unless ($ENV{PERL_AUTHOR_TESTING}) {
- plan skip_all => 'PERL_AUTHOR_TESTING environment variable not set';
-}
-
-eval "use Test::Pod::Coverage 1.00";
-if ($@) {
- plan skip_all => 'Test::Pod::Coverage 1.00 required for testing POD coverage';
-}
-
-all_pod_coverage_ok();
@@ -2,10 +2,6 @@ use strict;
use warnings;
use Test::More;
-unless ($ENV{PERL_AUTHOR_TESTING}) {
- plan skip_all => 'PERL_AUTHOR_TESTING environment variable not set';
-}
-
eval { require Test::Kwalitee; Test::Kwalitee->import() };
if ($@) {
plan skip_all => 'Test::Kwalitee not installed; skipping';
View
@@ -0,0 +1,11 @@
+use strict;
+use warnings;
+use Test::More;
+
+eval { require Test::Perl::Critic };
+if ($@) {
+ plan skip_all => "Test::Perl::Critic is not installed.";
+}
+Test::Perl::Critic->import;
+
+all_critic_ok(qw( ex lib t xt ));
View
@@ -2,10 +2,6 @@ use strict;
use warnings;
use Test::More;
-unless ($ENV{PERL_AUTHOR_TESTING}) {
- plan skip_all => 'PERL_AUTHOR_TESTING environment variable not set';
-}
-
eval "use Test::Pod 1.00";
if ($@) {
plan skip_all => 'Test::Pod 1.00 required for testing POD';
View
@@ -0,0 +1,9 @@
+use strict;
+use warnings;
+use Test::More;
+
+eval "use Test::Pod::Coverage 1.00";
+plan skip_all => 'Test::Pod::Coverage 1.00 required for testing POD coverage'
+ if $@;
+
+all_pod_coverage_ok();

0 comments on commit fa232e9

Please sign in to comment.