New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Stream throughput seems to be wrong #1047

Closed
bernd opened this Issue Jan 19, 2015 · 1 comment

Comments

Projects
None yet
2 participants
@bernd
Contributor

bernd commented Jan 19, 2015

The throughput display for a stream says 39 messages/second, the overall message throughput is 81 msg/s across 2 nodes. The stream rule for this stream has a presence check on the message field so the stream should have roughly the same throughput.

Both nodes have a random http message generator with the same settings. So both nodes emit around half of the overall messages. Since the stream throughput shows half of the overall throughput, I guess only one node is asked?

stream-throughput

@bernd bernd added the bug label Jan 19, 2015

@bernd bernd added this to the 1.0.0 milestone Jan 19, 2015

@bernd bernd changed the title from Stream throughput seems to be wrong. to Stream throughput seems to be wrong Jan 19, 2015

@dennisoelkers dennisoelkers self-assigned this Jan 20, 2015

@dennisoelkers

This comment has been minimized.

Contributor

dennisoelkers commented Jan 20, 2015

Fixed in d04f084

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment