New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

<> values in fields are unescaped and don't display in Quick Values #1455

Closed
NickMeves opened this Issue Jun 8, 2015 · 2 comments

Comments

Projects
None yet
4 participants
@NickMeves

NickMeves commented Jun 8, 2015

Version 1.1.1 - Multiple Browsers & OSes

If a field has components wrapped in <> (think a field like from extracted from emails: From: "Foo Bar" foo.bar@example.org). When the field is pulled up in quick values everything between <> is missing.

This occurs partially (above example "Foo Bar" is displayed) and fully (if a field were , it would appear blank in quick values).

I haven't fully tested, but I'm sure this might be occurring with all HTML snippets? Hopefully not a XSS vulnerability...?

@NickMeves

This comment has been minimized.

NickMeves commented Jun 8, 2015

Definitely XSS & security concerns. Markup is fully rendered. Quick Values on link data rendered the link exactly as specified in the field, including external resources.

@kroepke kroepke added the bug label Jun 8, 2015

@kroepke kroepke added this to the 1.1.2 milestone Jun 8, 2015

@kroepke

This comment has been minimized.

Contributor

kroepke commented Jun 8, 2015

Thanks! Will fix in the next bug fix release.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment