Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

SpnEn Not working on CNC Shield V3.00 whith gbrl 1.1f #1187

Closed
jhosorios opened this issue Feb 25, 2017 · 2 comments

Comments

Projects
None yet
2 participants
@jhosorios
Copy link

commented Feb 25, 2017

Hello, My Name is Jorge. I've Just try to reconfigure a CNC (shield V3.00) to a better performance and updated the firmware from Grbl0.8 to 1.1f. Everything it´s OK, the CNC works perfectly on the table, but now I have an issue (using Candle to send gcodes):
Whit the grbl0.8c and Universalgcodesender the SpnEn pins used to worked ok to turn on/off the spindle using a relay. But whit the new software those pins just stay on High. How can I automate this again?

@jhosorios

This comment has been minimized.

Copy link
Author

commented Feb 25, 2017

I found a solution:
Use the z+/gnd pins as on/off, on the command window set "S1000" and "eureka", The spindle turns on and off by itself.

@chamnit

This comment has been minimized.

Copy link
Member

commented Feb 25, 2017

Pins 11 and 12 swapped in v0.9 and after. This is to access the PWM hardware on pin 11 for spindle speed and zlimit is now pin 12. See the pin diagram in the wiki.

@chamnit chamnit closed this Feb 25, 2017

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.