Skip to content
This repository

Adding a @require fails #1504

Closed
arantius opened this Issue January 26, 2012 · 3 comments

1 participant

arantius
arantius
Collaborator

From #1502 (comment)


GM icon, little arrow to the right, New User Script..., Some Good Name, Somenamespace, empty description, /path//morepath/,
I get

// ==UserScript==
// @name Some Good Name
// @namespace Somenamespace
// @include */path//morepath/*
// ==/UserScript==

make it look

// ==UserScript==
// @name Some Good Name
// @namespace Somenamespace
// @require http://jquery.com/src/jquery-latest.js
// @include /path//morepath/*
// ==/UserScript==

alert("qwe");

Save, refresh page. Nothing happened. I can see script in list of page scripts on little arrow to the right of GM icon. Restart FF. Script disappears from this list. It still is in folder on disk (name with upper case characters), Config.xml have no records about this script. jquery-latest is not downloaded (in 0.9.14 when it was bugging, it used to be downloaded near Config.xml)
I have just repeated it again, same thing.


Confirmed, with error:

Error: this._uri is null
Source File: resource://greasemonkey/remoteScript.js
Line: 374

In GM 0.9.15.

arantius
Collaborator

Today I still see this failing, but without any error in the console.

arantius
Collaborator

@Dimps

The next nightly ( https://arantius.com/misc/gm-nightly/ ) should contain this fix. Confirmation would be great.

arantius
Collaborator

(... 208469d which hasn't (yet?) been automatically linked in

arantius arantius closed this February 06, 2012
arantius arantius referenced this issue from a commit in arantius/greasemonkey February 06, 2012
arantius Only examine the URI when we have one.
(In RemoteScript._downloadFile().)

Fixes #1504
208469d
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.