Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Scripts not openeing automatically in GM #1922

Closed
AlienHeads opened this Issue May 17, 2014 · 11 comments

Comments

Projects
None yet
6 participants
@AlienHeads
Copy link

commented May 17, 2014

FF 29.0.1
GM 1.15

Scripts open in the browser window instead of in GM. When i click a link to install a script it usually opens in GM, but as of today they have started opening in the browser window instead which is annoying as large scripts usually cause the browser to crash.

@jerone

This comment has been minimized.

Copy link
Contributor

commented May 17, 2014

You are sure GM is enabled?

@AlienHeads

This comment has been minimized.

Copy link
Author

commented May 18, 2014

Yes it is definitely enabled, was working fine until FF updated from 29.0 to 29.0.1

Your link doesn't work.

@jerone

This comment has been minimized.

Copy link
Contributor

commented May 18, 2014

hmmm, Github does something weird with the url. This is the original: http://wiki.greasespot.net/Greasemonkey_Manual:Monkey_Menu

@darkred

This comment has been minimized.

Copy link

commented May 18, 2014

I confirm the issue.
Now GM's behaviour is like Scriptish (which btw is by design ) as I had reported it in scriptish/scriptish#86
It happens in all links to .user.js file that I've encountered
(USO:8080, greasyfork, scripts in GitHub, etc)

@arantius arantius added this to the Pony milestone May 18, 2014

@AlienHeads

This comment has been minimized.

Copy link
Author

commented May 19, 2014

I can confirm this is the case on 6 other systems.

@janekptacijarabaci

This comment has been minimized.

Copy link
Contributor

commented May 21, 2014

@AlienHeads

This comment has been minimized.

Copy link
Author

commented May 22, 2014

Nothing there solved my problem, tried the latest Beta & also the add-on neither worked.

@janekptacijarabaci

This comment has been minimized.

Copy link
Contributor

commented May 22, 2014

I'm sorry.
Greasemonkey: service#shouldLoad will not starts

Conflict with "Adblock Plus 2.6" Firefox Addon (after disabled and restart Firefox OK)
all

See also #1681

@darkred

This comment has been minimized.

Copy link

commented May 22, 2014

Conflict with "Adblock Plus 2.6" Firefox Addon (after disabled and restart Firefox OK)

So, I've filed a bug in Adblock Plus forum
ABP and EHH cause scripts not to open automatically by GM

@Ventero

This comment has been minimized.

Copy link
Contributor

commented Sep 7, 2014

As per the upstream report (https://issues.adblockplus.org/ticket/546) - and confirmed by my own tests - this seems to be fixed now.

@janekptacijarabaci

This comment has been minimized.

Copy link
Contributor

commented Sep 7, 2014

I agree.

@arantius arantius closed this Sep 7, 2014

@arantius arantius added the worksforme label Sep 7, 2014

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.