Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Already tired of cpu high up bug #95

Open
elpedriyo opened this issue Apr 15, 2016 · 18 comments

Comments

Projects
None yet
3 participants
@elpedriyo
Copy link

commented Apr 15, 2016

The plugin highs up my cpu 50% because of this plugin, could you please solve it?
Here are the images:
My normal cpu-
image

The high cpu-
image

Please

@greatman

This comment has been minimized.

Copy link
Owner

commented Apr 15, 2016

Can you try to run this: https://raw.githubusercontent.com/major/MySQLTuner-perl/master/mysqltuner.pl ?

It will tell you if MySQL needs some tuning (cache, table open, etc) which can improves your CPU usage. Since I use a lot of keys /foreign keys it may improve performance quite a bit.

@elpedriyo

This comment has been minimized.

Copy link
Author

commented Apr 15, 2016

how do I run that?

@greatman

This comment has been minimized.

Copy link
Owner

commented Apr 15, 2016

It's a perl script, just wget it then do perl mysqltuner.pl
On Apr 14, 2016 11:49 PM, "elpedriyo" notifications@github.com wrote:

how do I run that?


You are receiving this because you commented.
Reply to this email directly or view it on GitHub
#95 (comment)

@elpedriyo

This comment has been minimized.

Copy link
Author

commented Apr 15, 2016

and do you recommend me to execute it when I have the cpu more than 50% because of mysql?

@elpedriyo

This comment has been minimized.

Copy link
Author

commented Apr 15, 2016

I also where monitoring task in mysql and I saw it is the select process from your plugin the problem, but I am going to run this now, to see what can I do

@elpedriyo

This comment has been minimized.

Copy link
Author

commented Apr 15, 2016

I got this when cpu was fine:
image

let me see now with it high

@elpedriyo

This comment has been minimized.

Copy link
Author

commented Apr 15, 2016

Ok, the other image when the cpu was up was the same

@greatman

This comment has been minimized.

Copy link
Owner

commented Apr 15, 2016

The script only asks that the mysql server has been running for more than
24h.
On Apr 14, 2016 11:58 PM, "elpedriyo" notifications@github.com wrote:

and do you recommend me to execute it when I have the cpu more than 50%
because of mysql?


You are receiving this because you commented.
Reply to this email directly or view it on GitHub
#95 (comment)

@elpedriyo

This comment has been minimized.

Copy link
Author

commented Apr 15, 2016

Ok, so then with the results you see, do you recommed something for optimizing this?
Because when your plugin launches the select query my cpu goes up to a 100% sometimes and this is horrible for all servers on the machine :/

@elpedriyo

This comment has been minimized.

Copy link
Author

commented Apr 15, 2016

Also it tells that the plugin is not closing mysql connections properly :/

@greatman

This comment has been minimized.

Copy link
Owner

commented Apr 15, 2016

Yeah well the script use the mysql stats it sees so having a large pool of data (aka at least 24h running) will provide somewhat accurate informations. Then we will see what is causing the issues. Sometimes a default MySQL config isn't enough for some workloads.

@elpedriyo

This comment has been minimized.

Copy link
Author

commented Apr 15, 2016

Ok, so then tomorrow I will paste you again what I see.
Another thing, at the startup of my servers I have always an error from craftconomy, could you please solve that?

@elpedriyo

This comment has been minimized.

Copy link
Author

commented Apr 15, 2016

Also when I introduce table_cache value mysql do not start again, I do not know if it is compatible with mysql 5.7

@elpedriyo

This comment has been minimized.

Copy link
Author

commented Apr 15, 2016

@greatman It is the same, the performance continue going bad when the plugin performs this:
image

Could you simply optimize the command?

@elpedriyo

This comment has been minimized.

Copy link
Author

commented Apr 15, 2016

The problem persists, it is a problem with the select function of the plugin every 3 or 4 minutes each time. Do not know why the plugin is making select function each 3 or 4 mintues

@elpedriyo

This comment has been minimized.

Copy link
Author

commented Apr 16, 2016

Ok, any solution, could you fix it?

@elpedriyo

This comment has been minimized.

Copy link
Author

commented Apr 16, 2016

I continue having the same problems

@netherstar

This comment has been minimized.

Copy link

commented Jul 18, 2017

is this issue is fixed in latest version?

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.