Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Syntax error with older perls #11

Open
eserte opened this issue Jul 31, 2019 · 1 comment

Comments

@eserte
Copy link

commented Jul 31, 2019

The test suite fails on older perls (<= 5.18):

#     Tried to use 'Device::Firewall::PaloAlto::Test::FIB'.
#     Error:  syntax error at lib/Device/Firewall/PaloAlto/Test/FIB.pm line 32, near "}{"

@gregfoletta gregfoletta self-assigned this Jul 31, 2019

@gregfoletta

This comment has been minimized.

Copy link
Owner

commented Jul 31, 2019

The pertinent line:

@ecmp_fib_entries = map { { %{ $_ }{qw(ip nh interface metric)} } } @{ $api_response->{result}{mpath}{entry} };

Key/Value slices added in Perl 5.20. Will modify this code to use something else.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
2 participants
You can’t perform that action at this time.