Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP
branch: master
Fetching contributors…

Cannot retrieve contributors at this time

104 lines (91 sloc) 3.483 kB
#
# Drm device configuration
#
# This driver provides support for the
# Direct Rendering Infrastructure (DRI) in XFree86 4.1.0 and higher.
#
config DRM
bool "Direct Rendering Manager (XFree86 4.1.0 and higher DRI support)"
help
Kernel-level support for the Direct Rendering Infrastructure (DRI)
introduced in XFree86 4.0. If you say Y here, you need to select
the module that's right for your graphics card from the list below.
These modules provide support for synchronization, security, and
DMA transfers. Please see <http://dri.sourceforge.net/> for more
details. You should also select and configure AGP
(/dev/agpgart) support.
config DRM_TDFX
tristate "3dfx Banshee/Voodoo3+"
depends on DRM && PCI
help
Choose this option if you have a 3dfx Banshee or Voodoo3 (or later),
graphics card. If M is selected, the module will be called tdfx.
config DRM_R128
tristate "ATI Rage 128"
depends on DRM && PCI
help
Choose this option if you have an ATI Rage 128 graphics card. If M
is selected, the module will be called r128. AGP support for
this card is strongly suggested (unless you have a PCI version).
config DRM_RADEON
tristate "ATI Radeon"
depends on DRM && PCI
help
Choose this option if you have an ATI Radeon graphics card. There
are both PCI and AGP versions. You don't need to choose this to
run the Radeon in plain VGA mode. There is a product page at
<http://www.ati.com/na/pages/products/pc/radeon32/index.html>.
If M is selected, the module will be called radeon.
config DRM_I810
tristate "Intel I810"
depends on DRM && AGP && AGP_INTEL
help
Choose this option if you have an Intel I810 graphics card. If M is
selected, the module will be called i810. AGP support is required
for this driver to work.
choice
prompt "Intel 830M, 845G, 852GM, 855GM, 865G"
depends on DRM && AGP && AGP_INTEL
optional
config DRM_I915
tristate "i915 driver"
depends on DRM && AGP && AGP_INTEL
help
Choose this option if you have a system that has Intel 830M, 845G,
852GM, 855GM, 865G, 915G, 915GM, 945G, 945GM and 965G integrated
graphics. If M is selected, the module will be called i915.
AGP support is required for this driver to work.
endchoice
config DRM_MGA
tristate "Matrox g200/g400"
depends on DRM && (!X86_64 || BROKEN) && (!PPC || BROKEN)
help
Choose this option if you have a Matrox G200, G400, G450 or G550
graphics card. If M is selected, the module will be called mga.
config DRM_SIS
tristate "SiS video cards"
depends on DRM
help
Choose this option if you have a SiS 630 or compatible video
chipset. If M is selected the module will be called sis.
config DRM_VIA
tristate "Via unichrome video cards"
depends on DRM
help
Choose this option if you have a Via unichrome or compatible video
chipset. If M is selected the module will be called via.
config DRM_MACH64
tristate "ATI Rage Pro (Mach64)"
depends on DRM && PCI
help
Choose this option if you have an ATI Rage Pro (mach64 chipset)
graphics card. Example cards include: 3D Rage Pro, Xpert 98,
3D Rage LT Pro, 3D Rage XL/XC, and 3D Rage Mobility (P/M, M1).
Cards earlier than ATI Rage Pro (e.g. Rage II) are not supported.
If M is selected, the module will be called mach64. AGP support for
this card is strongly suggested (unless you have a PCI version).
config DRM_PSB
tristate "Intel Poulsbo"
depends on DRM && PCI && I2C_ALGOBIT
help
Choose
Jump to Line
Something went wrong with that request. Please try again.