Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Browse files

Update for release 0.9.34.

  • Loading branch information...
commit d068dda639931774b289d7e567bed6b6b59f4e15 1 parent fc0c329
@mika mika authored
Showing with 33 additions and 8 deletions.
  1. +1 −1  debian/NEWS
  2. +29 −4 debian/changelog
  3. +3 −3 grml-live
View
2  debian/NEWS
@@ -13,7 +13,7 @@ grml-live (0.9.34) unstable; urgency=low
grml-live-db can work straight out-of-the-box. If you still want to
preserve your logfiles (e.g. when you don't want to use
grml-live-db) just enable the PRESERVE_LOGFILE option in your
- grml-live configuration file. For backwards compability reasons the
+ grml-live configuration file. For backwards compatibility reasons the
ZERO_LOGFILE variable is still supported within grml-live but it's
strongly recommended to adjust configuration.
View
33 debian/changelog
@@ -1,8 +1,33 @@
-grml-live (0.9.34) UNRELEASED; urgency=low
+grml-live (0.9.34) unstable; urgency=low
+
+ * Add scripts/GRMLBASE/38-udev to get rid of automatically generated
+ udev rules file.
+ * Fix architecture option in error message (-a instead of -i).
+ * Add ia32-libs [amd64] to Depends to make sure building i386 on amd64
+ works OOTB.
+ * Use $TEMPLATE_DIRECTORY for checking for precense of bsd4grml.
+ * Drop keyword package from squashfs binary exit code.
+ * Update docs regarding squashfs-tools 1:4.0-1.
+ * Support for logging to database via grml-live-db.
+ Thanks to formorer for his work on dpkg-to-db.
+ * Changed logic of ZERO_LOGFILE to PRESERVE_LOGFILE (though integrated
+ a backwared compatibility layer so existing installations still continue
+ to work) and clear logs after prompting for execution.
- * No changelog entries yet, will be inserted by git-dch.
-
- -- Michael Prokop <mika@grml.org> Wed, 30 Dec 2009 02:57:38 +0100
+ * Software related changes:
+ - Add acpi-support-base to GRML_SMALL [Closes: issue791]
+ - Add netsniff-ng to GRML_FULL (thanks Daniel Borkmann).
+ - Add ufsutils to GRML{SMALL,MEDIUM,FULL} [thanks, chaitat].
+ - Drop aufs-tools from GRML_FULL (deprecated, see #555638).
+ - Drop firescope from GRML_FULL - it is unmaintained upstream.
+ - Drop package config file GRML_FORENSIC as it is developed and
+ maintained as part of Grml-Forensic nowadays.
+ - Move scsiadd from GRML_* to GRMLBASE.
+ - Remove dynamic-disk from GRML_FULL (unmaintained upstream).
+ - Remove lame from GRML_FULL (not available from official Debian pool).
+ - Remove salvage-ntfs from GRML_FULL (unmaintained upstream).
+
+ -- Michael Prokop <mika@grml.org> Sat, 30 Jan 2010 19:56:32 +0100
grml-live (0.9.33) unstable; urgency=low
View
6 grml-live
@@ -288,7 +288,7 @@ ISO_OUTPUT="$OUTPUT/grml_isos"
[ -n "$RELEASENAME" ] && export RELEASENAME="$RELEASENAME"
# }}}
-# ZERO_LOGFILE - check for backwards compability reasons {{{
+# ZERO_LOGFILE - check for backwards compatibility reasons {{{
# this was default behaviour until grml-live 0.9.34:
if [ -n "$ZERO_LOGFILE" ] ; then
PRESERVE_LOGFILE='' # make sure it's cleaned then
@@ -898,7 +898,7 @@ else
bailout
fi
else # no $SQUASHFS_BINARY configured, let's find the according binary:
- # Note: this is ALL for backward compability and yes: it's serious PITA.
+ # Note: this is ALL for backward compatibility and yes: it's serious PITA.
# We'll definitely drop this once people build >2.6.28-grml* only and
# the squashfs-tools vs. squashfs-lzma-tools + zlib vs. lzma situation
# is settling...
@@ -913,7 +913,7 @@ else
else # neither -nolzma nor -z and mksquashfs-lzma is available:
SQUASHFS_BINARY='mksquashfs-lzma'
- # backwards compability: someone has squashfs-lzma-tools >=4 installed but
+ # backwards compatibility: someone has squashfs-lzma-tools >=4 installed but
# 1) doesn't use -nolzma in $SQUASHFS_OPTIONS or the grml-live's -z option *and*
# 2) builds against kernel version <=2.6.28-grml[64]
if ls $CHROOT_OUTPUT/boot/vmlinuz* >/dev/null 2>&1 ; then
Please sign in to comment.
Something went wrong with that request. Please try again.