Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
JavaScript

Fetching latest commit…

Cannot retrieve the latest commit at this time

Failed to load latest commit information.
.travis.yml
README.md
index.js
package.json

README.md

any-db-postgres

Build Status

This is the postgres adapter for Any-DB. It relies on the pg database driver to create Connection and Query objects that conform to the Any-DB API. The API is practically identical to that of require('pg') but allows your app code to be portable between databases.

API extensions

The connections and queries this package creates here are monkey-patched versions of the ones created by require('pg'), so any methods that pg supports beyond those specified by Any-DB are also available to you. Keep in mind that these methods will not necessarily work with other backends.

Pure Javascript driver

If you have issues using the native backend for the pg driver on your platform, you can force anyDB to use the pure-JavaScript driver like so:

require('any-db-postgres').forceJS = true

You must do the above before you create any connections or connection pools.

Install

npm install any-db-postgres

License

MIT

Something went wrong with that request. Please try again.