Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Browse files

Groovy all jar version should move along groovy version with maven su…

…pport tests rather than be fixed at 1.8.x
  • Loading branch information...
commit 6fee96e408432bac78b4ea8414c050c6f3393625 1 parent a495296
@kdvolder kdvolder authored
View
1  extras/groovy-eclipse-compiler-tests/pom.xml
@@ -10,6 +10,7 @@
<properties>
<project.build.sourceEncoding>UTF-8</project.build.sourceEncoding>
<groovy.xx.version>2.2.1-01-SNAPSHOT</groovy.xx.version>
+ <groovy.all.version>2.2.1</groovy.all.version> <!-- groovy all jar version to use for tests -->
<!-- only one of the below is actually used at any time and needs to be
replaced to run tests with different compiler. So we it it changed to use
just one property groovy.xx.version to represent all of them <groovy.22.version>2.2.0-01-SNAPSHOT</groovy.22.version>
View
2  extras/groovy-eclipse-compiler-tests/src/it/logging-ast-transform-test/pom.xml
@@ -25,7 +25,7 @@
<dependency>
<groupId>org.codehaus.groovy</groupId>
<artifactId>groovy-all</artifactId>
- <version>2.0.4</version>
+ <version>@groovy.all.version@</version>
<type>jar</type>
</dependency>
<dependency>
View
2  extras/groovy-eclipse-compiler-tests/src/it/lombok-test/pom.xml
@@ -14,7 +14,7 @@
<dependency>
<groupId>org.codehaus.groovy</groupId>
<artifactId>groovy-all</artifactId>
- <version>1.8.4</version>
+ <version>@groovy.all.version@</version>
</dependency>
<dependency>
View
2  extras/groovy-eclipse-compiler-tests/src/it/no-build-helper-use-mojo/pom.xml
@@ -40,7 +40,7 @@ xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/ma
<dependency>
<groupId>org.codehaus.groovy</groupId>
<artifactId>groovy-all</artifactId>
- <version>1.8.0</version>
+ <version>@groovy.all.version@</version>
</dependency>
<dependency>
<groupId>junit</groupId>
View
2  extras/groovy-eclipse-compiler-tests/src/it/no-build-helper/pom.xml
@@ -34,7 +34,7 @@
<dependency>
<groupId>org.codehaus.groovy</groupId>
<artifactId>groovy-all</artifactId>
- <version>1.8.0</version>
+ <version>@groovy.all.version@</version>
</dependency>
<dependency>
<groupId>junit</groupId>
View
2  extras/groovy-eclipse-compiler-tests/src/it/no-groovy/pom.xml
@@ -66,7 +66,7 @@ xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/ma
<dependency>
<groupId>org.codehaus.groovy</groupId>
<artifactId>groovy-all</artifactId>
- <version>1.8.0</version>
+ <version>@groovy.all.version@</version>
</dependency>
<dependency>
<groupId>junit</groupId>
View
2  extras/groovy-eclipse-compiler-tests/src/it/no-java-new-plexus-compiler/pom.xml
@@ -66,7 +66,7 @@ xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/ma
<dependency>
<groupId>org.codehaus.groovy</groupId>
<artifactId>groovy-all</artifactId>
- <version>1.8.0</version>
+ <version>@groovy.all.version@</version>
</dependency>
<dependency>
<groupId>junit</groupId>
View
2  extras/groovy-eclipse-compiler-tests/src/it/no-java/pom.xml
@@ -69,7 +69,7 @@ xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/ma
<dependency>
<groupId>org.codehaus.groovy</groupId>
<artifactId>groovy-all</artifactId>
- <version>1.8.0</version>
+ <version>@groovy.all.version@</version>
</dependency>
<dependency>
<groupId>junit</groupId>
View
2  extras/groovy-eclipse-compiler-tests/src/it/simple-it/pom.xml
@@ -66,7 +66,7 @@ xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/ma
<dependency>
<groupId>org.codehaus.groovy</groupId>
<artifactId>groovy-all</artifactId>
- <version>1.8.0</version>
+ <version>@groovy.all.version@</version>
</dependency>
<dependency>
<groupId>junit</groupId>
Please sign in to comment.
Something went wrong with that request. Please try again.