Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP
Browse files

Add Groovy 2.2 to update site. Plus small changes to build and psf.

  • Loading branch information...
commit 90172af9d6612dd43383f8ba0a047752a4452bda 1 parent cffad95
@kdvolder kdvolder authored
View
4 .gitignore
@@ -2,5 +2,7 @@ target
bin
bin-trace
antbin
+build
+workspace-build
.buildpath
-org.ebayopensource.vjet.eclipse.core.prefs
+org.ebayopensource.vjet.eclipse.core.prefs
View
7 groovy-eclipse-e43-project-set.psf
@@ -29,10 +29,11 @@
<project reference="1.0,git@github.com:groovy/groovy-eclipse.git,master,ide-test/org.codehaus.groovy.eclipse.refactoring.test"/>
<project reference="1.0,git@github.com:groovy/groovy-eclipse.git,master,ide-test/org.codehaus.groovy.eclipse.tests"/>
<project reference="1.0,git@github.com:groovy/groovy-eclipse.git,master,ide/org.codehaus.groovy.eclipse.ui"/>
-<project reference="1.0,git@github.com:groovy/groovy-eclipse.git,master,base/org.codehaus.groovy.frameworkadapter"/>
+<!-- <project reference="1.0,git@github.com:groovy/groovy-eclipse.git,master,base/org.codehaus.groovy.frameworkadapter"/> -->
<project reference="1.0,git@github.com:groovy/groovy-eclipse.git,master,extras/org.codehaus.groovy.m2eclipse"/>
<project reference="1.0,git@github.com:groovy/groovy-eclipse.git,master,base/org.codehaus.groovy18"/>
<project reference="1.0,git@github.com:groovy/groovy-eclipse.git,master,base/org.codehaus.groovy20"/>
+<project reference="1.0,git@github.com:groovy/groovy-eclipse.git,master,base/org.codehaus.groovy21"/>
<project reference="1.0,git@github.com:groovy/groovy-eclipse.git,master,base/org.codehaus.groovy22"/>
<project reference="1.0,git@github.com:groovy/groovy-eclipse.git,master,jdt-patch/e42/org.eclipse.jdt.core"/>
<project reference="1.0,git@github.com:groovy/groovy-eclipse.git,master,jdt-patch/e42/Feature org.codehaus.groovy.jdt.patch"/>
@@ -64,6 +65,8 @@
<item elementID="=org.codehaus.groovy.frameworkadapter" factoryID="org.eclipse.jdt.ui.PersistableJavaElementFactory"/>
<item elementID="=org.codehaus.groovy.eclipse.codeassist.completion" factoryID="org.eclipse.jdt.ui.PersistableJavaElementFactory"/>
<item elementID="=org.codehaus.groovy20" factoryID="org.eclipse.jdt.ui.PersistableJavaElementFactory"/>
+<item elementID="=org.codehaus.groovy21" factoryID="org.eclipse.jdt.ui.PersistableJavaElementFactory"/>
+<item elementID="=org.codehaus.groovy22" factoryID="org.eclipse.jdt.ui.PersistableJavaElementFactory"/>
<item elementID="=org.codehaus.groovy.eclipse.ant" factoryID="org.eclipse.jdt.ui.PersistableJavaElementFactory"/>
<item elementID="=org.codehaus.groovy.eclipse.quickfix.test" factoryID="org.eclipse.jdt.ui.PersistableJavaElementFactory"/>
<item elementID="=org.codehaus.groovy.eclipse.refactoring" factoryID="org.eclipse.jdt.ui.PersistableJavaElementFactory"/>
@@ -81,4 +84,4 @@
<item elementID="=org.eclipse.jdt.groovy.core" factoryID="org.eclipse.jdt.ui.PersistableJavaElementFactory"/>
<item elementID="=org.codehaus.groovy.m2eclipse" factoryID="org.eclipse.jdt.ui.PersistableJavaElementFactory"/>
</workingSets>
-</psf>
+</psf>
View
6 ide/org.codehaus.groovy.eclipse.pluginbuilder/build.xml
@@ -126,9 +126,9 @@
<param name="theDir" value="${build.eclipse.dir}" />
</antcall>
<!-- force building with 1.7 -->
- <install-feature eclipse.loc="${build.eclipse.dir}/eclipse" feature.id="org.codehaus.groovy17.feature" updatesite.url="http://dist.springsource.org/release/GRECLIPSE/e4.2/" />
- <install-feature eclipse.loc="${build.eclipse.dir}/eclipse" feature.id="org.codehaus.groovy.headless.feature" updatesite.url="http://dist.springsource.org/release/GRECLIPSE/e4.2/" />
- <install-bundle eclipse.loc="${build.eclipse.dir}/eclipse" bundle.id="org.codehaus.groovy.eclipse.ant" updatesite.url="http://dist.springsource.org/release/GRECLIPSE/e4.2/" />
+ <install-feature eclipse.loc="${build.eclipse.dir}/eclipse" feature.id="org.codehaus.groovy17.feature" updatesite.url="${greclipse.update.site}" />
+ <install-feature eclipse.loc="${build.eclipse.dir}/eclipse" feature.id="org.codehaus.groovy.headless.feature" updatesite.url="${greclipse.update.site}" />
+ <install-bundle eclipse.loc="${build.eclipse.dir}/eclipse" bundle.id="org.codehaus.groovy.eclipse.ant" updatesite.url="${greclipse.update.site}" />
</target>
View
3  ide/org.codehaus.groovy.eclipse.pluginbuilder/build_local_e37.properties
@@ -92,4 +92,5 @@ build.eclipse.zip=/opt/bamboo-home/downloaded-eclipses/eclipse-SDK-4.2RC4-linux-
orig.jdt.feature.version.range=[3.7.0.v20110121-7z8fFb7FMTfESMtR15KlAcZ9H155,3.7.0.v20110121-7z8fFb7FMTfESMtR15KlAcZ9H155]
new.jdt.feature.version.range=[3.7.0,3.7.3)
-eclipse.update.site=http://download.eclipse.org/releases/indigo
+eclipse.update.site=http://download.eclipse.org/releases/indigo
+greclipse.update.site=http://dist.springsource.org/release/GRECLIPSE/e4.2/
View
4 ide/org.codehaus.groovy.eclipse.pluginbuilder/build_local_e42.properties
@@ -14,6 +14,7 @@
# limitations under the License.
###############################################################################
+# point this to the root of greclipse repo git clone.
workDir=${user.dir}/../GRECLIPSE-E42-JOB1
# The location of this project. It provides the base directory for the build scripts.
@@ -89,4 +90,5 @@ build.eclipse.zip=/opt/bamboo-home/downloaded-eclipses/eclipse-SDK-4.2RC4-linux-
orig.jdt.feature.version.range=[3.8.0.v20111130-1318-8-8lFpEFNOfwRe0lvGVLmVw9B15B,3.8.0.v20111130-1318-8-8lFpEFNOfwRe0lvGVLmVw9B15B]
new.jdt.feature.version.range=[3.8.0,3.8.3)
-eclipse.update.site=http://download.eclipse.org/releases/juno/
+eclipse.update.site=http://download.eclipse.org/releases/juno/
+greclipse.update.site=http://dist.springsource.org/release/GRECLIPSE/e4.2/
View
9 ide/org.codehaus.groovy.eclipse.pluginbuilder/build_local_e43.properties
@@ -14,7 +14,9 @@
# limitations under the License.
###############################################################################
+# point this to the root of greclipse repo git clone.
workDir=${user.dir}/../GRECLIPSE-E43-JOB1
+#workDir=/home/kdvolder/commandline-dev/groovy-eclipse
# The location of this project. It provides the base directory for the build scripts.
buildHome=${workDir}/ide/org.codehaus.groovy.eclipse.pluginbuilder
@@ -80,11 +82,11 @@ workspaceDirJdtPatch=${workDir}/jdt-patch/e43
buildTypePresentation=e43
# the location of the eclipse tarball to build against
-target.eclipse.zip=/opt/bamboo-home/downloaded-eclipses/eclipse-SDK-4.3M6-linux-gtk-x86_64.tar.gz
+target.eclipse.zip=/home/kdvolder/Desktop/Downloads/eclipse-standard-kepler-R-linux-gtk-x86_64.tar.gz
# the location of the eclipse tarball to build with (usually the same as the target eclipse)
-build.eclipse.zip=/opt/bamboo-home/downloaded-eclipses/eclipse-SDK-4.2RC4-linux-gtk-x86_64.tar.gz
+build.eclipse.zip=/home/kdvolder/Desktop/Downloads/eclipse-standard-kepler-R-linux-gtk-x86_64.tar.gz
# the original and new target versions of the JDT feature. This change gets reflected in the content.xml
@@ -93,4 +95,5 @@ build.eclipse.zip=/opt/bamboo-home/downloaded-eclipses/eclipse-SDK-4.2RC4-linux-
orig.jdt.feature.version.range=[3.9.0.v20121210-132935-8-8uFyYFNOfwKNWRqxYHNBDV3834,3.9.0.v20121210-132935-8-8uFyYFNOfwKNWRqxYHNBDV3834]
new.jdt.feature.version.range=[3.9.0,3.9.3)
-eclipse.update.site=http://download.eclipse.org/releases/juno/
+eclipse.update.site=http://download.eclipse.org/releases/kepler/
+greclipse.update.site=http://dist.springsource.org/release/GRECLIPSE/e4.3/
View
3  ide/org.codehaus.groovy.eclipse.pluginbuilder/legal/site.xml
@@ -34,6 +34,9 @@
<feature url="features/org.codehaus.groovy21.feature_0.0.0.qualifier.jar" id="org.codehaus.groovy21.feature" version="0.0.0.qualifier">
<category name="org.codehaus.groovy.compilers"/>
</feature>
+ <feature url="features/org.codehaus.groovy22.feature_0.0.0.qualifier.jar" id="org.codehaus.groovy22.feature" version="0.0.0.qualifier">
+ <category name="org.codehaus.groovy.compilers"/>
+ </feature>
<category-def name="org.codehaus.groovy.eclipse.sdk" label="Groovy Eclipse SDK (Optional)">
<description>
Optional feature that provides source code for the Groovy-Eclipse plugin
Please sign in to comment.
Something went wrong with that request. Please try again.