Permalink
Browse files

upgrade to jquery-mobile v1.1.0

  • Loading branch information...
1 parent 55c6022 commit 7c6198805a027ddd89086a71f29b42bbf1455d25 Karol Balejko committed Apr 23, 2012
@@ -1,6 +1,6 @@
class JqueryMobileGrailsPlugin {
// the plugin version
- def version = "1.0.4"
+ def version = "1.1.0.5"
// the version or versions of Grails the plugin is designed for
def grailsVersion = "1.3.7 > *"
// the other plugins this plugin depends on
View
@@ -10,7 +10,9 @@ Including the resources
You must use the Grails resources framework to make use of this plugin. The resources exposed by this plugin are:
- jquery-mobile - jQuery mobile framework css and js (version 1.0.1)
+ jquery-mobile - jQuery mobile framework css and js (version 1.1.0)
+
+
Usage
-----
@@ -20,15 +22,13 @@ Usage
Versioning
----------
-Pluging version pattern is (jq-mobile-version).(plugin-version)
+Plugin version convention is <jq-mobile-version>.<plugin-version>
-NOTE
-----
+History
+-------
-jQueryMobile 1.0 supports jQuery core 1.6.4 only.
-(see http://jquerymobile.com/blog/2011/11/16/announcing-jquery-mobile-1-0/#upgrade)
-Plugin overrides jquery resource module to jQuery core v1.6.4
+1.1.0.5 Upgrade to jquery-mobile v1.1.0 final. Upgrade notes here http://jquerymobile.com/blog/2012/04/13/announcing-jquery-mobile-1-1-0/
Copyright and License
@@ -1,22 +1,8 @@
modules = {
- /*
- * NOTE:
- * http://jquerymobile.com/blog/2011/11/16/announcing-jquery-mobile-1-0/#upgrade
- * Reminder: 1.0 supports jQuery core 1.6.4 only
- * Since 1.7 was just recently released and has some significant changes (and improvements),
- * only 1.6.4 is officially >supported at this time. We plan on adding 1.7 support when
- * we release version 1.1.
- */
- overrides {
- jquery {
- resource id:'js', url:[plugin: 'jquery-mobile', dir: 'js', file: 'jquery-1.6.4.js'], disposition: 'head'
- }
- }
-
'jquery-mobile' {
dependsOn 'jquery'
- resource url:[plugin: 'jquery-mobile', dir: 'css', file: 'jquery.mobile-1.0.1.css'], disposition: 'head'
- resource url:[plugin: 'jquery-mobile', dir: 'js', file: 'jquery.mobile-1.0.1.js'], disposition: 'head'
+ resource url:[plugin: 'jquery-mobile', dir: 'css', file: 'jquery.mobile-1.1.0.css'], disposition: 'head'
+ resource url:[plugin: 'jquery-mobile', dir: 'js', file: 'jquery.mobile-1.1.0.js'], disposition: 'head'
}
}
View
@@ -1,4 +1,4 @@
-<plugin name='jquery-mobile' version='1.0.4' grailsVersion='1.3.7 &gt; *'>
+<plugin name='jquery-mobile' version='1.1.0.5' grailsVersion='1.3.7 &gt; *'>
<author>Karol Balejko</author>
<authorEmail>kb@groovydev.org</authorEmail>
<title>Plugin jQuery mobile framework resource files</title>
Sorry, something went wrong. Reload?
Sorry, we cannot display this file.
Sorry, this file is invalid so it cannot be displayed.
Sorry, something went wrong. Reload?
Sorry, we cannot display this file.
Sorry, this file is invalid so it cannot be displayed.
Sorry, something went wrong. Reload?
Sorry, we cannot display this file.
Sorry, this file is invalid so it cannot be displayed.
Sorry, something went wrong. Reload?
Sorry, we cannot display this file.
Sorry, this file is invalid so it cannot be displayed.
Sorry, something went wrong. Reload?
Sorry, we cannot display this file.
Sorry, this file is invalid so it cannot be displayed.
Oops, something went wrong.
Oops, something went wrong.
Oops, something went wrong.

0 comments on commit 7c61988

Please sign in to comment.