Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP
Browse files

- update dependency to jq core 1.6.4

- images update
- update plugin dependency
  • Loading branch information...
commit ab5c5bf08421218aefe70a03be494fb20756b51f 1 parent 662bc13
Karol Balejko authored
View
5 JqueryMobileGrailsPlugin.groovy
@@ -1,10 +1,11 @@
class JqueryMobileGrailsPlugin {
// the plugin version
- def version = "1.0"
+ def version = "1.0.3"
// the version or versions of Grails the plugin is designed for
def grailsVersion = "1.3.7 > *"
// the other plugins this plugin depends on
- def dependsOn = ['resources':'1.0 > *', 'jquery':'1.7 > *']
+ def dependsOn = ['resources':'1.0 > *', 'jquery':'1.6 > *']
+
// resources that are excluded from plugin packaging
def pluginExcludes = [
"grails-app/views/error.gsp"
View
8 README.md
@@ -10,12 +10,18 @@ Including the resources
You must use the Grails resources framework to make use of this plugin. The resources exposed by this plugin are:
- jquery-mobile - jQuery mobile framework css and js (version 1.0rc1)
+ jquery-mobile - jQuery mobile framework css and js (version 1.0 final)
Usage
-----
<r:require modules="jquery-mobile"/>
+
+Versioning
+----------
+
+Pluging version pattern is <jq-mobile-version>.<plugin-version>
+
Copyright and License
---------------------
View
4 grails-app/conf/BuildConfig.groovy
@@ -29,8 +29,8 @@ grails.project.dependency.resolution = {
// runtime 'mysql:mysql-connector-java:5.1.13'
}
plugins {
- compile ":jquery:1.6.1.1"
- compile ":resources:1.0.1"
+ compile ":jquery:latest.integration"
+ compile ":resources:latest.integration"
build ":release:latest.integration", {
export = false
}
View
14 grails-app/conf/JqueryMobileResources.groovy
@@ -1,4 +1,18 @@
modules = {
+
+ /*
+ * NOTE:
+ * http://jquerymobile.com/blog/2011/11/16/announcing-jquery-mobile-1-0/#upgrade
+ * Reminder: 1.0 supports jQuery core 1.6.4 only
+ * Since 1.7 was just recently released and has some significant changes (and improvements),
+ * only 1.6.4 is officially >supported at this time. We plan on adding 1.7 support when
+ * we release version 1.1.
+ */
+ overrides {
+ jquery {
+ resource id:'js', url:[plugin: 'jquery-mobile', dir: 'js', file: 'jquery-1.6.4.js'], disposition: 'head'
+ }
+ }
'jquery-mobile' {
dependsOn 'jquery'
View
BIN  web-app/css/images/ajax-loader.png
Sorry, something went wrong. Reload?
Sorry, we cannot display this file.
Sorry, this file is invalid so it cannot be displayed.
View
BIN  web-app/css/images/icons-18-black.png
Sorry, something went wrong. Reload?
Sorry, we cannot display this file.
Sorry, this file is invalid so it cannot be displayed.
View
BIN  web-app/css/images/icons-18-white.png
Sorry, something went wrong. Reload?
Sorry, we cannot display this file.
Sorry, this file is invalid so it cannot be displayed.
View
BIN  web-app/css/images/icons-36-black.png
Sorry, something went wrong. Reload?
Sorry, we cannot display this file.
Sorry, this file is invalid so it cannot be displayed.
View
BIN  web-app/css/images/icons-36-white.png
Sorry, something went wrong. Reload?
Sorry, we cannot display this file.
Sorry, this file is invalid so it cannot be displayed.
View
2  web-app/css/jquery.mobile-1.0.css
@@ -1,5 +1,5 @@
/*
-* jQuery Mobile Framework Git Build: SHA1: ed6a08489708b68de614ddd5bf2f6f4bfd1cb36a <> Date: Thu Nov 17 11:25:15 2011 -0500
+* jQuery Mobile Framework 1.0
* http://jquerymobile.com
*
* Copyright 2011 (c) jQuery Project
View
BIN  web-app/images/ajax-loader.png
Deleted file not rendered
View
BIN  web-app/images/icons-18-black.png
Deleted file not rendered
View
BIN  web-app/images/icons-18-white.png
Deleted file not rendered
View
BIN  web-app/images/icons-36-black.png
Deleted file not rendered
View
BIN  web-app/images/icons-36-white.png
Deleted file not rendered
View
9,046 web-app/js/jquery-1.6.4.js
9,046 additions, 0 deletions not shown
View
54 web-app/js/jquery.mobile-1.0.js
@@ -1,5 +1,5 @@
/*
-* jQuery Mobile Framework Git Build: SHA1: ed6a08489708b68de614ddd5bf2f6f4bfd1cb36a <> Date: Thu Nov 17 11:25:15 2011 -0500
+* jQuery Mobile Framework 1.0
* http://jquerymobile.com
*
* Copyright 2011 (c) jQuery Project
@@ -3859,8 +3859,7 @@ $.widget( "mobile.collapsible", $.mobile.widget, {
collapsible = $el.addClass( "ui-collapsible" ),
collapsibleHeading = $el.children( o.heading ).first(),
collapsibleContent = collapsible.wrapInner( "<div class='ui-collapsible-content'></div>" ).find( ".ui-collapsible-content" ),
- collapsibleSet = $el.closest( ":jqmData(role='collapsible-set')" ).addClass( "ui-collapsible-set" ),
- collapsiblesInSet = collapsibleSet.children( ":jqmData(role='collapsible')" );
+ collapsibleSet = $el.closest( ":jqmData(role='collapsible-set')" ).addClass( "ui-collapsible-set" );
// Replace collapsibleHeading if it's a legend
if ( collapsibleHeading.is( "legend" ) ) {
@@ -3897,52 +3896,9 @@ $.widget( "mobile.collapsible", $.mobile.widget, {
iconPos: "left",
icon: "plus",
theme: o.theme
- });
-
- if ( !collapsibleSet.length ) {
- collapsibleHeading
- .find( "a" ).first().add( collapsibleHeading.find( ".ui-btn-inner" ) )
- .addClass( "ui-corner-top ui-corner-bottom" );
- } else {
- // If we are in a collapsible set
-
- // Initialize the collapsible set if it's not already initialized
- if ( !collapsibleSet.jqmData( "collapsiblebound" ) ) {
-
- collapsibleSet
- .jqmData( "collapsiblebound", true )
- .bind( "expand", function( event ) {
-
- $( event.target )
- .closest( ".ui-collapsible" )
- .siblings( ".ui-collapsible" )
- .trigger( "collapse" );
-
- });
- }
-
- collapsiblesInSet.first()
- .find( "a" )
- .first()
- .addClass( "ui-corner-top" )
- .find( ".ui-btn-inner" )
- .addClass( "ui-corner-top" );
-
- collapsiblesInSet.last()
- .jqmData( "collapsible-last", true )
- .find( "a" )
- .first()
- .addClass( "ui-corner-bottom" )
- .find( ".ui-btn-inner" )
- .addClass( "ui-corner-bottom" );
-
-
- if ( collapsible.jqmData( "collapsible-last" ) ) {
- collapsibleHeading
- .find( "a" ).first().add ( collapsibleHeading.find( ".ui-btn-inner" ) )
- .addClass( "ui-corner-bottom" );
- }
- }
+ })
+ .add( ".ui-btn-inner" )
+ .addClass( "ui-corner-top ui-corner-bottom" );
//events
collapsible
Please sign in to comment.
Something went wrong with that request. Please try again.