Permalink
Browse files

hamlet seems to be dead...

  • Loading branch information...
1 parent a05b941 commit f649ff4877b6610205dfb66e153eaaa9382c66ab @grosser committed Nov 10, 2012
View
@@ -5,7 +5,6 @@ gem 'appraisal'
gem 'bump'
gem 'gettext'
gem 'haml'
-gem 'hamlet'
gem 'rails'
gem 'rake'
gem 'ruby_parser', '~> 2.3' # 3 breaks haml/slim parsing
View
@@ -46,8 +46,6 @@ GEM
gettext (2.3.3)
locale
haml (3.1.7)
- hamlet (0.5.0.1)
- slim (~> 1.0.0)
hike (1.2.1)
i18n (0.6.1)
journey (1.0.4)
@@ -121,7 +119,6 @@ DEPENDENCIES
gettext
gettext_i18n_rails!
haml
- hamlet
rails
rake
rspec
View
@@ -28,7 +28,7 @@ Setup
##### Optional:
Add `gettext` if you want to find translations or build .mo files<br/>
-Add `ruby_parser` if you want to find translations inside haml/slim/hamlet files (does not support ruby 1.9 syntax)
+Add `ruby_parser` if you want to find translations inside haml/slim files (does not support ruby 1.9 syntax)
# Gemfile
@@ -6,7 +6,6 @@ gem "appraisal"
gem "bump"
gem "gettext"
gem "haml"
-gem "hamlet"
gem "rake"
gem "ruby_parser", "~> 2.3"
gem "rspec"
@@ -26,8 +26,6 @@ GEM
gettext (2.3.3)
locale
haml (3.1.7)
- hamlet (0.5.0.1)
- slim (~> 1.0.0)
locale (2.0.8)
rack (1.1.3)
rails (2.3.14)
@@ -65,7 +63,6 @@ DEPENDENCIES
gettext
gettext_i18n_rails!
haml
- hamlet
rails (~> 2.3.0)
rake
rspec
@@ -6,7 +6,6 @@ gem "appraisal"
gem "bump"
gem "gettext"
gem "haml"
-gem "hamlet"
gem "rake"
gem "ruby_parser", "~> 2.3"
gem "rspec"
@@ -47,8 +47,6 @@ GEM
gettext (2.3.3)
locale
haml (3.1.7)
- hamlet (0.5.0.1)
- slim (~> 1.0.0)
i18n (0.5.0)
json (1.7.5)
locale (2.0.8)
@@ -113,7 +111,6 @@ DEPENDENCIES
gettext
gettext_i18n_rails!
haml
- hamlet
rails (~> 3.0.0)
rake
rspec
@@ -6,7 +6,6 @@ gem "appraisal"
gem "bump"
gem "gettext"
gem "haml"
-gem "hamlet"
gem "rake"
gem "ruby_parser", "~> 2.3"
gem "rspec"
@@ -47,8 +47,6 @@ GEM
gettext (2.3.3)
locale
haml (3.1.7)
- hamlet (0.5.0.1)
- slim (~> 1.0.0)
hike (1.2.1)
i18n (0.6.1)
json (1.7.5)
@@ -123,7 +121,6 @@ DEPENDENCIES
gettext
gettext_i18n_rails!
haml
- hamlet
rails (~> 3.1.0)
rake
rspec
@@ -6,7 +6,6 @@ gem "appraisal"
gem "bump"
gem "gettext"
gem "haml"
-gem "hamlet"
gem "rake"
gem "ruby_parser", "~> 2.3"
gem "rspec"
@@ -46,8 +46,6 @@ GEM
gettext (2.3.3)
locale
haml (3.1.7)
- hamlet (0.5.0.1)
- slim (~> 1.0.0)
hike (1.2.1)
i18n (0.6.1)
journey (1.0.4)
@@ -121,7 +119,6 @@ DEPENDENCIES
gettext
gettext_i18n_rails!
haml
- hamlet
rails (~> 3.2.0)
rake
rspec
@@ -1,15 +0,0 @@
-require 'gettext_i18n_rails/base_parser'
-
-module GettextI18nRails
- class HamletParser < BaseParser
- def self.extension
- "hamlet"
- end
-
- def self.convert_to_code(text)
- Hamlet::Engine.new.call(text)
- end
- end
-end
-
-GettextI18nRails::GettextHooks.add_parser GettextI18nRails::HamletParser
@@ -16,7 +16,6 @@ def load_gettext
$LOAD_PATH << File.join(File.dirname(__FILE__),'..','..','lib') # needed when installed as plugin
require "gettext_i18n_rails/haml_parser"
- require "gettext_i18n_rails/hamlet_parser"
require "gettext_i18n_rails/slim_parser"
if GetText.respond_to? :update_pofiles_org
@@ -1,43 +0,0 @@
-require "spec_helper"
-require "gettext_i18n_rails/hamlet_parser"
-
-describe GettextI18nRails::HamletParser do
- def pending_if(xx, &block)
- if xx
- pending(&block)
- else
- yield
- end
- end
-
- let(:parser){ GettextI18nRails::HamletParser }
-
- describe "#target?" do
- it "targets .hamlet" do
- parser.target?('foo/bar/xxx.hamlet').should == true
- end
-
- it "does not target anything else" do
- parser.target?('foo/bar/xxx.erb').should == false
- end
- end
-
- describe "#parse" do
- it "finds messages in hamlet" do
- pending_if(RUBY_VERSION < "1.9") do
- with_file '<div>= _("xxxx")' do |path|
- parser.parse(path, []).should == [
- ["xxxx", "#{path}:1"]
- ]
- end
- end
- end
-
- it "does not find messages in text" do
- with_file '<div> _("xxxx")' do |path|
- parser.parse(path, []).should == []
- end
- end
- end
-end
-

0 comments on commit f649ff4

Please sign in to comment.