Permalink
Browse files

make tests run a bit on 1.9

  • Loading branch information...
1 parent eb43e76 commit b1bcfd6cb462d9b7bc994ac48e1c818bc9422354 @grosser committed Oct 23, 2012
Showing with 20 additions and 1 deletion.
  1. +4 −0 Gemfile
  2. +12 −0 Gemfile.lock
  3. +1 −0 Rakefile
  4. +1 −1 setup.rb
  5. +1 −0 test/test_header.rb
  6. +1 −0 test/test_mail.rb
View
@@ -0,0 +1,4 @@
+source :rubygems
+
+gem "rake"
+gem "test-unit", "2.5.2"
View
@@ -0,0 +1,12 @@
+GEM
+ remote: http://rubygems.org/
+ specs:
+ rake (0.9.2.2)
+ test-unit (2.5.2)
+
+PLATFORMS
+ ruby
+
+DEPENDENCIES
+ rake
+ test-unit (= 2.5.2)
View
@@ -1,2 +1,3 @@
require File.join(File.dirname(__FILE__), "setup.rb")
+task :default => :test
View
@@ -682,7 +682,7 @@ def exec_test
setup_rb_error 'test/unit cannot loaded. You need Ruby 1.8 or later to invoke this task.'
end
autorunner = Test::Unit::AutoRunner.new(true)
- autorunner.to_run << 'test'
+ autorunner.process_args(["test"])
autorunner.run
else # use testrb
opt = []
View
@@ -1,3 +1,4 @@
+# encoding: utf-8
$:.unshift File.dirname(__FILE__)
require 'test_helper'
require 'tmail'
View
@@ -1,3 +1,4 @@
+# encoding: utf-8
$:.unshift File.dirname(__FILE__)
require 'test_helper'
require 'tmail'

0 comments on commit b1bcfd6

Please sign in to comment.