Skip to content

Prerequisites

Koen edited this page Aug 1, 2019 · 2 revisions

The scaffold has the following requirements:

  • PHP 7.1+ with Composer
  • Node 8+ with Yarn (used for front-end tooling)
  • Ruby 2.2+ with Bundler (used for deployments)

To run WordPress itself, you'll either need to..:

  • Spin up the provided Docker container (to be added shortly)
  • Have a web server like Apache or nginx with PHP and a MySQL/MariaDB server. A good starting point is this guide.

Installation instructions

Here are some pointers if you're missing dependencies. This assumes you're using macOS and have Homebrew installed.

PHP

Used to run WordPress, and to be able to use Composer. If you're missing it, it can installed via Homebrew:

$ brew install php

Composer

Used for dependency management. View the installation instructions, or install via Homebrew:

$ brew install composer

Node

Used for running the front-end tooling. View the installation instructions, or install via Homebrew:

$ brew install node

You could also use nvm for easier version management.

Yarn

Yarn is used for package management. View the installation guide, or install via Homebrew:

$ brew install yarn

Ruby

macOS is bundled with a fixed Ruby version. This requires sudo if you want to install any packages, so it's recommended to use a custom version. It can installed via Homebrew:

$ brew install ruby

You could also use rbenv for easier version management:

$ brew install rbenv
$ rbenv init
$ rbenv install <version>

Bundler

Used for dependency management. View the installation instructions, or install as a Ruby gem:

$ gem install bundler
You can’t perform that action at this time.