Skip to content

0.4.1 is a MAJOR update, not a minor one #48

Closed
chrisabrams opened this Issue Mar 1, 2013 · 6 comments

3 participants

@chrisabrams

I should not upgrade from 0.4.0 to 0.4.1 and have my app completely break. The update includes a MAJOR update on the Coffeescript side (1.4.0 to 1.5.0). Why is this only considered a minor update on the Grunt side?

I'm specifically referring to this Coffeescript update jashkenas/coffeescript#2715 which has broken so many apps.

@davidkaneda

Also, just out of curiosity... The module updated automatically when specified at "~0.4.0RC7" to "0.4.1" — Is this common behavior for Node modules? (I'd think ~ only meant "latest at this version number...")

@chrisabrams

It would seem "rc" versions are kinda in limbo https://npmjs.org/doc/json.html as they are never really discussed.

@tkellen
grunt member
tkellen commented Mar 1, 2013

You're right Chris, this was an oversight on my part. I will fix it shortly.

@tkellen
grunt member
tkellen commented Mar 1, 2013

Fixed.

@tkellen tkellen closed this Mar 1, 2013
@chrisabrams

Thanks @tkellen!

@tkellen
grunt member
tkellen commented Mar 1, 2013

Sure thing. Sorry about that--it never should have happened!

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.