Skip to content

Error: Cannot find module 'jshint/src/cli/cli after latest JSHint release #92

Closed
wachunga opened this Issue Aug 15, 2013 · 6 comments

6 participants

@wachunga

The JSHint crew moved cli.js in 2.1.10 so this plugin is broken.

@mllrjb
mllrjb commented Aug 15, 2013

+1, just ran into this as well.

@shama shama closed this in b0b504b Aug 15, 2013
@shama
grunt member
shama commented Aug 15, 2013

Fixed. I was afraid that this would happen. If it breaks again, I'll just peg the version and update it manually. That will avoid this task from breaking like this. Sorry guys!

@tschaub
tschaub commented Aug 18, 2013

+1 for pegging dependencies to avoid future breakage

@wachunga

I also think pegging JSHint is the way to go here, given you're relying on internals.

@boompig
boompig commented Feb 23, 2015

Also ran into this issue in building jquery-ui

@guy-mograbi-at-gigaspaces

+1 me too when I downgraded to v0.6.0

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.