Permalink
Browse files

Fix gemspec that was requiring guard/compass, which was requiring gua…

…rd and compass, before anything else! So without guard and compass already installed on the machine, it was impossible to `bundle install`.
  • Loading branch information...
1 parent 126240e commit b9bb9db683b93b4904f4e4bbdf6ab09f1d386a35 Rémy Coutable committed Dec 2, 2010
Showing with 7 additions and 4 deletions.
  1. +2 −2 guard-compass.gemspec
  2. +0 −2 lib/guard/compass.rb
  3. +5 −0 lib/guard/compass/version.rb
View
@@ -1,10 +1,10 @@
# -*- encoding: utf-8 -*-
$:.push File.expand_path('../lib', __FILE__)
-require 'guard/compass'
+require 'guard/compass/version'
Gem::Specification.new do |s|
s.name = 'guard-compass'
- s.version = Guard::Compass::VERSION
+ s.version = Guard::CompassVersion::VERSION
s.platform = Gem::Platform::RUBY
s.authors = ['Olivier Amblet']
s.email = ['olivier@amblet.net']
View
@@ -9,8 +9,6 @@ module Guard
class Compass < Guard
attr_reader :updater
- VERSION = '0.0.6'
-
def initialize(watchers = [], options = {})
super
@options[:workdir] = File.expand_path(File.dirname("."))
@@ -0,0 +1,5 @@
+module Guard
+ module CompassVersion
+ VERSION = '0.0.6'
+ end
+end

0 comments on commit b9bb9db

Please sign in to comment.