Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Browse files

configure travis

  • Loading branch information...
commit 966b8e6bf16e7fd78668e06deb22c1b7aacdf254 1 parent a5479b1
@yannlugrin yannlugrin authored
View
3  .gitignore
@@ -2,6 +2,7 @@ pkg/*
*.gem
.bundle
Gemfile.lock
+/gemfiles/*.lock
## MAC OS
.DS_Store
@@ -9,4 +10,4 @@ Gemfile.lock
.com.apple.timemachine.supported
.fseventsd
Desktop DB
-Desktop DF
+Desktop DF
View
21 .travis.yml
@@ -1,4 +1,23 @@
+branches:
+ only:
+ - master
rvm:
- 1.8.7
- 1.9.2
- - ree
+ # - 1.9.3
+ # - ree
+ # - jruby-18mode
+ # - jruby-19mode
+ # - rbx-18mode
+ # - rbx-19mode
+gemfile:
+ - gemfiles/minitest-1.7
+ # - gemfiles/minitest-2.0
+ - gemfiles/minitest-2.1
+matrix:
+ exclude:
+ - rvm: 1.8.7
+ gemfile: gemfiles/minitest-2.1
+notifications:
+ recipients:
+ - yann.lugrin@sans-savoir.net
View
22 Gemfile
@@ -4,19 +4,13 @@ gemspec
gem 'rake'
-# optional development dependencies
require 'rbconfig'
-
-if Config::CONFIG['target_os'] =~ /darwin/i
- gem 'rb-fsevent', '>= 0.3.2'
- gem 'growl', '~> 1.0.3'
-end
-if Config::CONFIG['target_os'] =~ /linux/i
- gem 'rb-inotify', '>= 0.5.1'
- gem 'libnotify', '~> 0.1.3'
-end
-if RbConfig::CONFIG['target_os'] =~ /mswin|mingw/i
- gem 'win32console', :require => false
- gem 'rb-fchange', '~> 0.0.2', :require => false
- gem 'rb-notifu', '~> 0.0.4', :require => false
+if RbConfig::CONFIG['target_os'] =~ /darwin/i
+ gem 'ruby_gntp', '~> 0.3.4', :require => false
+elsif RbConfig::CONFIG['target_os'] =~ /linux/i
+ gem 'libnotify', '~> 0.7.1', :require => false
+elsif RbConfig::CONFIG['target_os'] =~ /mswin|mingw/i
+ gem 'win32console', :require => false
+ gem 'rb-notifu', '>= 0.0.4', :require => false
end
+
View
2  README.rdoc
@@ -1,5 +1,7 @@
= Guard::Minitest
+{<img src="https://secure.travis-ci.org/guard/guard-minitest.png" />}[http://travis-ci.org/guard/guard-minitest]
+
Minitest guard allows to automatically & intelligently launch tests with
{minitest framework}[http://github.com/seattlerb/minitest] when files are modified.
View
12 Rakefile
@@ -47,11 +47,9 @@ namespace(:test) do
echo "minitest version 1 - `ruby -v`";
for ((c=1; c<$ruby_version_string_size+21; c++)); do echo -n "="; done
echo;
- minitest_version=1 bundle install;
- minitest_version=1 bundle exec rake test 2>&1'
+ BUNDLE_GEMFILE=./gemfiles/minitest-1.7 bundle install;
+ BUNDLE_GEMFILE=./gemfiles/minitest-1.7 bundle exec rake test 2>&1'
BASH
- puts version.class
- puts version
if version =~ /^1\.9/
system <<-BASH
bash -c 'source ~/.rvm/scripts/rvm;
@@ -63,11 +61,11 @@ namespace(:test) do
echo "minitest version 2 - `ruby -v`";
for ((c=1; c<$ruby_version_string_size+21; c++)); do echo -n "="; done
echo;
- minitest_version=2 bundle install;
- minitest_version=2 bundle exec rake test 2>&1'
+ BUNDLE_GEMFILE=./gemfiles/minitest-2.1 bundle install;
+ BUNDLE_GEMFILE=./gemfiles/minitest-2.1 bundle exec rake test 2>&1'
BASH
end
end
end
end
-end
+end
View
8 gemfiles/minitest-1.7
@@ -0,0 +1,8 @@
+source 'http://rubygems.org'
+
+gem 'rake'
+gem 'guard', '~> 0.4'
+gem 'minitest', '~> 1.7.2'
+gem 'bundler', '~> 1.0.2'
+gem 'mocha', '~> 0.9.8'
+
View
8 gemfiles/minitest-2.0
@@ -0,0 +1,8 @@
+source 'http://rubygems.org'
+
+gem 'rake'
+gem 'guard', '~> 0.4'
+gem 'minitest', '~> 2.0.0'
+gem 'bundler', '~> 1.0.2'
+gem 'mocha', '~> 0.9.8'
+
View
8 gemfiles/minitest-2.1
@@ -0,0 +1,8 @@
+source 'http://rubygems.org'
+
+gem 'rake'
+gem 'guard', '~> 0.4'
+gem 'minitest', '~> 2.1.0'
+gem 'bundler', '~> 1.0.2'
+gem 'mocha', '~> 0.9.8'
+
View
9 guard-minitest.gemspec
@@ -17,14 +17,7 @@ Gem::Specification.new do |s|
s.add_dependency 'guard', '~> 0.4'
- # Use this environment variable only for testing
- if ENV["minitest_version"] =~ /^1/
- s.add_development_dependency 'minitest', '~> 1.7.2'
- elsif ENV["minitest_version"] =~ /^2\.0/
- s.add_development_dependency 'minitest', '~> 2.0.0'
- else
- s.add_development_dependency 'minitest', '~> 2.1.0'
- end
+ s.add_development_dependency 'minitest', '~> 2.1.0'
s.add_development_dependency 'bundler', '>= 1.0.2'
s.add_development_dependency 'mocha', '>= 0.9.8'
Please sign in to comment.
Something went wrong with that request. Please try again.