Permalink
Browse files

Update dependencies for current guard.

  • Loading branch information...
1 parent 6d974f3 commit 5482e07624b14fff740ff297eb11039e09938344 @fnichol fnichol committed Jan 7, 2013
Showing with 11 additions and 10 deletions.
  1. +1 −0 .gitignore
  2. +6 −0 Gemfile
  3. +1 −6 Guardfile
  4. +3 −4 guard-webrick.gemspec
View
1 .gitignore
@@ -3,3 +3,4 @@
Gemfile.lock
pkg/*
.rvmrc
+tmp/
View
6 Gemfile
@@ -3,6 +3,12 @@ source "http://rubygems.org"
# Specify your gem's dependencies in guard-webrick.gemspec
gemspec
+group :development do
+ gem 'rb-inotify', :require => false
+ gem 'rb-fsevent', :require => false
+ gem 'rb-fchange', :require => false
+end
+
group :test do
gem 'rake', '~> 0.9'
end
View
7 Guardfile
@@ -1,9 +1,4 @@
-guard 'bundler' do
- watch(/^Gemfile/)
- watch(/^.+\.gemspec/)
-end
-
-guard 'rspec', :version => 2 do
+guard 'rspec' do
watch(/^spec\/.*_spec\.rb/)
watch(/^lib\/(.*)\.rb/) { |m| "spec/#{m[1]}_spec.rb" }
watch(/^spec\/spec_helper\.rb/) { "spec" }
View
7 guard-webrick.gemspec
@@ -15,13 +15,12 @@ Gem::Specification.new do |s|
s.required_rubygems_version = '>= 1.3.6'
s.rubyforge_project = "guard-webrick"
- s.add_dependency 'guard', '~> 1.0.2'
+ s.add_dependency 'guard', '~> 1.0'
s.add_dependency 'spoon', '~> 0.0.1'
s.add_dependency 'launchy', '~> 2.1.0'
- s.add_development_dependency 'rspec', '~> 2.5.0'
- s.add_development_dependency 'guard-rspec', '~> 0.7.0'
- s.add_development_dependency 'guard-bundler', '~> 0.1.1'
+ s.add_development_dependency 'rspec', '~> 2.5'
+ s.add_development_dependency 'guard-rspec'
s.files = `git ls-files`.split("\n")
s.test_files = `git ls-files -- {test,spec,features}/*`.split("\n")

0 comments on commit 5482e07

Please sign in to comment.